Re: [PATCH v4 5/5] http: rename HTTP_REAUTH to HTTP_RETRY
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Mar 13, 2012, 17:51 UTC
- Message-ID
- <7vy5r4wfru.fsf@alter.siamese.dyndns.org>
- In-Reply-To
- <4F5F41FF.4000204@seap.minhap.es>
Nelson Benitez Leon <nelsonjesus.benitez@seap.minhap.es> writes:
Show 11 quoted lines
> On 03/12/2012 09:06 PM, Junio C Hamano wrote: >> Whatever new token you use, please keep AUTH as a substring of it. >> >> We may want to retry a request to deal with intermittent failures on >> the server side or the network between us and the server; HTTP_RETRY >> would be a good name to signal such condition after we see a failure >> response from the library. > > HTTP_REAUTH and HTTP_AUTH_RETRY seems like the same thing, so imo not > deserving the rename, maybe Jeff can suggest a better name as he was > who suggest the rename.
Either has AUTH as a substring in it, and leaves a door open for us to later introduce HTTP_RETRY to tell the machinery that drives cURL library to retry the request, so in that sense I am OK with either, but as your log message said, we want to make it clear that this is not about doing the authentication again (re-auth) but retrying the authentication, so HTTP_AUTH_RETRY would be more logical name.