git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v4 5/5] http: rename HTTP_REAUTH to HTTP_RETRY

From
Junio C Hamano <gitster@pobox.com>
Date
Mar 13, 2012, 23:05 UTC
Message-ID
<7v1uowt83u.fsf@alter.siamese.dyndns.org>
In-Reply-To
<20120313220411.GA28357@sigill.intra.peff.net>
Jeff King <peff@peff.net> writes:
Show 14 quoted lines
> On Tue, Mar 13, 2012 at 10:51:33AM -0700, Junio C Hamano wrote:
>
>> Either has AUTH as a substring in it, and leaves a door open for us to
>> later introduce HTTP_RETRY to tell the machinery that drives cURL library
>> to retry the request, so in that sense I am OK with either, but as your
>> log message said, we want to make it clear that this is not about doing
>> the authentication again (re-auth) but retrying the authentication, so
>> HTTP_AUTH_RETRY would be more logical name.
>
> I suggested RETRY because that is all the caller needs to know: the
> http_request machinery said "please call me again". Keep in mind that
> this is a private interface within http.c, and this return code should
> never make it out at all. Nor is it something anybody else would feed
> us.

Oh, the potential "retry when a request failed" in the future I had in mind was also contained within http.c. Perhaps HTTP_RETRY could be used for the same purpose? The places I had in mind that we may potentially want to retry are where we got 50x from one of the servers in the pool that serves the name we are accessing, we got 401 from the server to let us realize we gave it a wrong credential, or we got 407 from the proxy to notify a similar situation, and all are potential candidate for retrying in the client may help. The credential might have been mistyped for 40x, or we may hit a healthy server in the same pool for 50x.

Previous: Jeff KingNext: Nelson Benitez Leon
Message 6 of 8 in “http: rename HTTP_REAUTH to HTTP_RETRY”
  1. 5/5 http: rename HTTP_REAUTH to HTTP_RETRYNelson Benitez Leon, Mar 12, 2012
  2. Junio C HamanoMar 12, 2012
  3. Nelson Benitez LeonMar 13, 2012
  4. Junio C HamanoMar 13, 2012
  5. Jeff KingMar 13, 2012
  6. Junio C HamanoMar 13, 2012
  7. Nelson Benitez LeonMar 14, 2012
  8. Junio C HamanoMar 14, 2012

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.