git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v4 5/5] http: rename HTTP_REAUTH to HTTP_RETRY

From
Jeff King <peff@peff.net>
Date
Mar 13, 2012, 22:04 UTC
Message-ID
<20120313220411.GA28357@sigill.intra.peff.net>
In-Reply-To
<7vy5r4wfru.fsf@alter.siamese.dyndns.org>
On Tue, Mar 13, 2012 at 10:51:33AM -0700, Junio C Hamano wrote:
Show 18 quoted lines
> > On 03/12/2012 09:06 PM, Junio C Hamano wrote:
> >> Whatever new token you use, please keep AUTH as a substring of it.
> >> 
> >> We may want to retry a request to deal with intermittent failures on
> >> the server side or the network between us and the server; HTTP_RETRY
> >> would be a good name to signal such condition after we see a failure
> >> response from the library.
> >
> > HTTP_REAUTH and HTTP_AUTH_RETRY seems like the same thing, so imo not 
> > deserving the rename, maybe Jeff can suggest a better name as he was
> > who suggest the rename.
> 
> Either has AUTH as a substring in it, and leaves a door open for us to
> later introduce HTTP_RETRY to tell the machinery that drives cURL library
> to retry the request, so in that sense I am OK with either, but as your
> log message said, we want to make it clear that this is not about doing
> the authentication again (re-auth) but retrying the authentication, so
> HTTP_AUTH_RETRY would be more logical name.

I suggested RETRY because that is all the caller needs to know: the http_request machinery said "please call me again". Keep in mind that this is a private interface within http.c, and this return code should never make it out at all. Nor is it something anybody else would feed us.

I am half-tempted to suggest refactoring it to return the actual error code, and let the caller handle 401 and 407. That would be more readable overall, I think. But it's a little complicated, because getting the exact answer depends on the curl handle, which is local to http_request, and I don't want to hold Nelson's actual feature improvement hostage to such refactoring.

-Peff
Previous: Junio C HamanoNext: Junio C Hamano
Message 5 of 8 in “http: rename HTTP_REAUTH to HTTP_RETRY”
  1. 5/5 http: rename HTTP_REAUTH to HTTP_RETRYNelson Benitez Leon, Mar 12, 2012
  2. Junio C HamanoMar 12, 2012
  3. Nelson Benitez LeonMar 13, 2012
  4. Junio C HamanoMar 13, 2012
  5. Jeff KingMar 13, 2012
  6. Junio C HamanoMar 13, 2012
  7. Nelson Benitez LeonMar 14, 2012
  8. Junio C HamanoMar 14, 2012

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.