Re: [PATCH 00/22] cache cursors: an introduction
- From
- Tim Ottinger <tottinge@progeny.com>
- Date
- Sep 13, 2005, 19:06 UTC
- Message-ID
- <43272350.3060801@progeny.com>
- In-Reply-To
- <4325AED6.8050401@citi.umich.edu>
I know it's a little picky, but can we be consistently noun-verb-noun with these? I'm not meaning to be a jerk (it just happens unbidden).
My reasons 1) My editor has word completion, which is handy. 2) However unimportant, I'm an old OO guy and object_cmd looks like object.command to me. 3) I'm so stupid I need consistent naming to help me learn the git guts. 4) I'm generally a butt about naming anyway (http://tottinge.blogsome.com/naming-rules/) 5) I work with a guy who is a stickler for lexicon, and he revived the passion for consistency.
> which describes a position in the cache. > > + init_cc
cc_init?
> > + next_cc, prev_cc, cache_eof
cc_next, cc_previous
Which is that, cc_to_end or cc_at_end?
> + next_name
cc_next_name?
> > + walk_cache
cache_walk?
The rest of those looked great. I only listed the ones I was unsure about.
--
><>
... either 'way ahead of the game, or 'way out in left field.