Re: [PATCH 00/22] cache cursors: an introduction
- From
- Chuck Lever <cel@citi.umich.edu>
- Date
- Sep 14, 2005, 14:49 UTC
- Message-ID
- <43283888.10909@citi.umich.edu>
- In-Reply-To
- <tnxu0gocats.fsf@arm.com>
Catalin Marinas wrote:
Show 9 quoted lines
> Tim Ottinger <tottinge@progeny.com> wrote: > >>2) However unimportant, I'm an old OO guy and object_cmd looks like >>object.command to me. > > > Well, it depends on the language. If you only used LISP/CLOS, it would > look more like (cmd object) :-) >
just a note on function naming: i followed the pre-existing function naming convention. to wit:
existing:
read_cache write_cache add_cache_entry remove_cache_entry_at
new:
init_cc next_cc walk_cache
etc.
begin:vcard fn:Chuck Lever n:Lever;Charles org:Network Appliance, Incorporated;Linux NFS Client Development adr:535 West William Street, Suite 3100;;Center for Information Technology Integration;Ann Arbor;MI;48103-4943;USA email;internet:cel@citi.umich.edu title:Member of Technical Staff tel;work:+1 734 763 4415 tel;fax:+1 734 763 4434 tel;home:+1 734 668 1089 x-mozilla-html:FALSE url:http://www.monkey.org/~cel/ version:2.1 end:vcard