git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 7/8] Documentation/git-repo: replace 'NUL' with '_NUL_'

From
Lucas Seiki Oshiro <lucasseikioshiro@gmail.com>
Date
Feb 18, 2026, 21:08 UTC
Message-ID
<20260218211845.96009-8-lucasseikioshiro@gmail.com>
In-Reply-To
<20260218211845.96009-1-lucasseikioshiro@gmail.com>

Replace all occurrences of "NUL" by "_NUL_" in git-repo.adoc, following the convention used by other documentation files.

Signed-off-by: Lucas Seiki Oshiro <lucasseikioshiro@gmail.com>
---
 Documentation/git-repo.adoc | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Documentation/git-repo.adoc b/Documentation/git-repo.adoc
index 319d30bd86..f76f579b20 100644
--- a/Documentation/git-repo.adoc
+++ b/Documentation/git-repo.adoc
@@ -40,7 +40,7 @@ supported:
 
 `nul`:::
 	similar to `lines`, but using a newline character as the delimiter
-	between the key and the value and using a NUL character after each value.
+	between the key and the value and using a _NUL_ character after each value.
 	This format is better suited for being parsed by another applications than
 	`lines`. Unlike in the `lines` format, the values are never quoted.
 +
@@ -80,7 +80,7 @@ supported:
 	configuration variable `core.quotePath` (see linkgit:git-config[1]).
 
 `nul`:::
-	Similar to `lines`, but uses a NUL character to delimit between
+	Similar to `lines`, but uses a _NUL_ character to delimit between
 	key-value pairs instead of a newline. Also uses a newline character as
 	the delimiter between the key and value instead of '='. Unlike the
 	`lines` format, values containing "unusual" characters are never
-- 
2.50.1 (Apple Git-155)
Previous: Lucas Seiki OshiroNext: Lucas Seiki Oshiro
Message 12 of 24 in “repo: refactoring leftover nits”
  1. 0/8 repo: refactoring leftover nitsLucas Seiki Oshiro, Feb 18, 2026
  2. 1/8 CodingGuidelines: instruct to name arrays in singularLucas Seiki Oshiro, Feb 18, 2026
  3. Eric SunshineFeb 19, 2026
  4. Lucas Seiki OshiroFeb 22, 2026
  5. 2/8 repo: rename repo_info_fields to repo_info_fieldLucas Seiki Oshiro, Feb 18, 2026
  6. 3/8 repo: replace get_value_fn_for_key by get_repo_info_fieldLucas Seiki Oshiro, Feb 18, 2026
  7. 4/8 repo: rename struct field to repo_info_fieldLucas Seiki Oshiro, Feb 18, 2026
  8. 5/8 t1900: rename t1900-repo to t1900-repo-infoLucas Seiki Oshiro, Feb 18, 2026
  9. 6/8 t1901: use tr in git repo structure output instead of expected valueLucas Seiki Oshiro, Feb 18, 2026
  10. Patrick SteinhardtFeb 20, 2026
  11. Lucas Seiki OshiroFeb 22, 2026
  12. 7/8 Documentation/git-repo: replace 'NUL' with '_NUL_'Lucas Seiki Oshiro, Feb 18, 2026
  13. 8/8 Documentation/git-repo: capitalize format descriptionsLucas Seiki Oshiro, Feb 18, 2026
  14. 0/8 repo: refactoring leftover nitsLucas Seiki Oshiro, Feb 25, 2026
  15. 1/8 CodingGuidelines: instruct to name arrays in singularLucas Seiki Oshiro, Feb 25, 2026
  16. 2/8 repo: rename repo_info_fields to repo_info_fieldLucas Seiki Oshiro, Feb 25, 2026
  17. 3/8 repo: replace get_value_fn_for_key by get_repo_info_fieldLucas Seiki Oshiro, Feb 25, 2026
  18. 4/8 repo: rename struct field to repo_info_fieldLucas Seiki Oshiro, Feb 25, 2026
  19. 5/8 t1900: rename t1900-repo to t1900-repo-infoLucas Seiki Oshiro, Feb 25, 2026
  20. 6/8 t1901: adjust nul format output instead of expected valueLucas Seiki Oshiro, Feb 25, 2026
  21. 7/8 Documentation/git-repo: replace 'NUL' with '_NUL_'Lucas Seiki Oshiro, Feb 25, 2026
  22. 8/8 Documentation/git-repo: capitalize format descriptionsLucas Seiki Oshiro, Feb 25, 2026
  23. Lucas Seiki OshiroFeb 25, 2026
  24. Junio C HamanoFeb 25, 2026

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.