git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 0/8] repo: refactoring leftover nits

From
Lucas Seiki Oshiro <lucasseikioshiro@gmail.com>
Date
Feb 18, 2026, 21:08 UTC
Message-ID
<20260218211845.96009-1-lucasseikioshiro@gmail.com>
Hi!

This patchset refactors git-repo-info after some suggestions and after the introduction of git-repo-structure. These changes were made:

1. CodingGuidelines now contains a instruction for naming arrays in
   singular (based on [1])
2. Rename a variable to its singular form in repo.c (based on [1])
3. Replace the function `get_value_fn_for_key` by a new function
   `get_repo_info_field` and make the structure of the function `print_fields` closer to the
   function `print_all_fields` (based on [1])
4. Rename the struct `field` to `repo_info_field` (after git-repo-structure)
5. Rename t1900-repo to t1900-repo-info (after git-repo-structure)
6. Use `tr` in output instead of the expected value (based on [2])
7. Replace `NUL` by `_NUL_` in the documentation (based on [3])
8. Capitalize some paragraphs in the documentation (based on [4])

This patch is based on top of master 59438b41ab (Merge branch 'master' of github.com:git/git, 2026-02-18) with lo/repo-info-keys merged.

[1] xmqqh5usiizp.fsf@gitster.g [2] xmqqh5txfv7b.fsf@gitster.g [3] 12814829.O9o76ZdvQC@piment-oiseau [4] aXhiIQXBvMhzkFy9@pks.im

Lucas Seiki Oshiro (8):
  CodingGuidelines: instruct to name arrays in singular
  repo: rename repo_info_fields to repo_info_field
  repo: replace get_value_fn_for_key by get_repo_info_field
  repo: rename struct field to repo_info_field
  t1900: rename t1900-repo to t1900-repo-info
  t1901: use tr in git repo structure output instead of expected value
  Documentation/git-repo: replace 'NUL' with '_NUL_'
  Documentation/git-repo: capitalize format descriptions
 Documentation/CodingGuidelines          |  8 +++++
 Documentation/git-repo.adoc             |  8 ++---
 builtin/repo.c                          | 44 ++++++++++++-------------
 t/meson.build                           |  2 +-
 t/{t1900-repo.sh => t1900-repo-info.sh} |  0
 t/t1901-repo-structure.sh               |  8 ++---
 6 files changed, 39 insertions(+), 31 deletions(-)
 rename t/{t1900-repo.sh => t1900-repo-info.sh} (100%)
-- 
2.50.1 (Apple Git-155)
Next: Lucas Seiki Oshiro
Message 1 of 24 in “repo: refactoring leftover nits”
  1. 0/8 repo: refactoring leftover nitsLucas Seiki Oshiro, Feb 18, 2026
  2. 1/8 CodingGuidelines: instruct to name arrays in singularLucas Seiki Oshiro, Feb 18, 2026
  3. Eric SunshineFeb 19, 2026
  4. Lucas Seiki OshiroFeb 22, 2026
  5. 2/8 repo: rename repo_info_fields to repo_info_fieldLucas Seiki Oshiro, Feb 18, 2026
  6. 3/8 repo: replace get_value_fn_for_key by get_repo_info_fieldLucas Seiki Oshiro, Feb 18, 2026
  7. 4/8 repo: rename struct field to repo_info_fieldLucas Seiki Oshiro, Feb 18, 2026
  8. 5/8 t1900: rename t1900-repo to t1900-repo-infoLucas Seiki Oshiro, Feb 18, 2026
  9. 6/8 t1901: use tr in git repo structure output instead of expected valueLucas Seiki Oshiro, Feb 18, 2026
  10. Patrick SteinhardtFeb 20, 2026
  11. Lucas Seiki OshiroFeb 22, 2026
  12. 7/8 Documentation/git-repo: replace 'NUL' with '_NUL_'Lucas Seiki Oshiro, Feb 18, 2026
  13. 8/8 Documentation/git-repo: capitalize format descriptionsLucas Seiki Oshiro, Feb 18, 2026
  14. 0/8 repo: refactoring leftover nitsLucas Seiki Oshiro, Feb 25, 2026
  15. 1/8 CodingGuidelines: instruct to name arrays in singularLucas Seiki Oshiro, Feb 25, 2026
  16. 2/8 repo: rename repo_info_fields to repo_info_fieldLucas Seiki Oshiro, Feb 25, 2026
  17. 3/8 repo: replace get_value_fn_for_key by get_repo_info_fieldLucas Seiki Oshiro, Feb 25, 2026
  18. 4/8 repo: rename struct field to repo_info_fieldLucas Seiki Oshiro, Feb 25, 2026
  19. 5/8 t1900: rename t1900-repo to t1900-repo-infoLucas Seiki Oshiro, Feb 25, 2026
  20. 6/8 t1901: adjust nul format output instead of expected valueLucas Seiki Oshiro, Feb 25, 2026
  21. 7/8 Documentation/git-repo: replace 'NUL' with '_NUL_'Lucas Seiki Oshiro, Feb 25, 2026
  22. 8/8 Documentation/git-repo: capitalize format descriptionsLucas Seiki Oshiro, Feb 25, 2026
  23. Lucas Seiki OshiroFeb 25, 2026
  24. Junio C HamanoFeb 25, 2026

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.