git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 6/8] t1901: use tr in git repo structure output instead of expected value

From
Lucas Seiki Oshiro <lucasseikioshiro@gmail.com>
Date
Feb 22, 2026, 22:35 UTC
Message-ID
<052D94B7-D26B-4308-8349-159F16BDA6CC@gmail.com>
In-Reply-To
<aZgzmlVfuXgI2UJ9@pks.im>
Show 10 quoted lines
>> The test 'keyvalue and nul format', as it description says, test both
>> keyvalue and nul format. These formats are similar, differing only in
>> their field separator (= in the former, LF in the latter) and their
>> record separator (LF in the former, NUL in the latter). This way, both
>> formats can be tested using the same expected output and only replacing
>> the separators in one of the output formats.
> 
> Hm, okay. I have to admit I don't quite understand what we gain here. We
> have to use tr(1) regardless of how we do it, and I cannot see that
> either of these alternatives is clearly superior compared to the other.

I should be clearer about this in my description. Of course, both approaches work here but this won't output a NUL character if the test fails, which could be considered as a binary file to diff.

Actually, this is something that Junio saw in a previous patch, and this was his comment about it [1]:

Show 7 quoted lines
> * Instead of munging the expected file so that it contains a NUL,
>   and compare the actual output with it, munge the NUL terminated
>   outout to make it text and compare with the expected file in text
>   format. This matters when tests start to fail as test_cmp will
>   show the "diff" output when it fails, and comparing NUL
>   terminated files, which are "binary" in the eyes of the "diff"
>   utility.
But anyway, I'll make it clear in my next version.
Thanks!
[1] xmqqh5txfv7b.fsf@gitster.g
Previous: Patrick SteinhardtNext: Lucas Seiki Oshiro
Message 11 of 24 in “repo: refactoring leftover nits”
  1. 0/8 repo: refactoring leftover nitsLucas Seiki Oshiro, Feb 18, 2026
  2. 1/8 CodingGuidelines: instruct to name arrays in singularLucas Seiki Oshiro, Feb 18, 2026
  3. Eric SunshineFeb 19, 2026
  4. Lucas Seiki OshiroFeb 22, 2026
  5. 2/8 repo: rename repo_info_fields to repo_info_fieldLucas Seiki Oshiro, Feb 18, 2026
  6. 3/8 repo: replace get_value_fn_for_key by get_repo_info_fieldLucas Seiki Oshiro, Feb 18, 2026
  7. 4/8 repo: rename struct field to repo_info_fieldLucas Seiki Oshiro, Feb 18, 2026
  8. 5/8 t1900: rename t1900-repo to t1900-repo-infoLucas Seiki Oshiro, Feb 18, 2026
  9. 6/8 t1901: use tr in git repo structure output instead of expected valueLucas Seiki Oshiro, Feb 18, 2026
  10. Patrick SteinhardtFeb 20, 2026
  11. Lucas Seiki OshiroFeb 22, 2026
  12. 7/8 Documentation/git-repo: replace 'NUL' with '_NUL_'Lucas Seiki Oshiro, Feb 18, 2026
  13. 8/8 Documentation/git-repo: capitalize format descriptionsLucas Seiki Oshiro, Feb 18, 2026
  14. 0/8 repo: refactoring leftover nitsLucas Seiki Oshiro, Feb 25, 2026
  15. 1/8 CodingGuidelines: instruct to name arrays in singularLucas Seiki Oshiro, Feb 25, 2026
  16. 2/8 repo: rename repo_info_fields to repo_info_fieldLucas Seiki Oshiro, Feb 25, 2026
  17. 3/8 repo: replace get_value_fn_for_key by get_repo_info_fieldLucas Seiki Oshiro, Feb 25, 2026
  18. 4/8 repo: rename struct field to repo_info_fieldLucas Seiki Oshiro, Feb 25, 2026
  19. 5/8 t1900: rename t1900-repo to t1900-repo-infoLucas Seiki Oshiro, Feb 25, 2026
  20. 6/8 t1901: adjust nul format output instead of expected valueLucas Seiki Oshiro, Feb 25, 2026
  21. 7/8 Documentation/git-repo: replace 'NUL' with '_NUL_'Lucas Seiki Oshiro, Feb 25, 2026
  22. 8/8 Documentation/git-repo: capitalize format descriptionsLucas Seiki Oshiro, Feb 25, 2026
  23. Lucas Seiki OshiroFeb 25, 2026
  24. Junio C HamanoFeb 25, 2026

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.