Hi!
This patchset refactors git-repo-info after some suggestions and after the introduction of git-repo-structure. These changes were made:
1. CodingGuidelines now contains a instruction for naming arrays in singular (based on [1])
2. Rename a variable to its singular form in repo.c (based on [1])
3. Replace the function `get_value_fn_for_key` by a new function `get_repo_info_field` and make the structure of the function `print_fields` closer to the function `print_all_fields` (based on [1])
4. Rename the struct `field` to `repo_info_field` (after git-repo-structure)
5. Rename t1900-repo to t1900-repo-info (after git-repo-structure)
6. Use `tr` in output instead of the expected value (based on [2])
7. Replace `NUL` by `_NUL_` in the documentation (based on [3])
8. Capitalize some paragraphs in the documentation (based on [4])
This patch is based on top of master 59438b41ab (Merge branch 'master' of github.com:git/git, 2026-02-18) with lo/repo-info-keys merged.
[1] xmqqh5usiizp.fsf@gitster.g [2] xmqqh5txfv7b.fsf@gitster.g [3] 12814829.O9o76ZdvQC@piment-oiseau [4] aXhiIQXBvMhzkFy9@pks.im
Lucas Seiki Oshiro (8): CodingGuidelines: instruct to name arrays in singular repo: rename repo_info_fields to repo_info_field repo: replace get_value_fn_for_key by get_repo_info_field repo: rename struct field to repo_info_field t1900: rename t1900-repo to t1900-repo-info t1901: use tr in git repo structure output instead of expected value Documentation/git-repo: replace 'NUL' with '_NUL_' Documentation/git-repo: capitalize format descriptions
Documentation/CodingGuidelines | 8 +++++
Documentation/git-repo.adoc | 8 ++---
builtin/repo.c | 44 ++++++++++++-------------
t/meson.build | 2 +-
t/{t1900-repo.sh => t1900-repo-info.sh} | 0
t/t1901-repo-structure.sh | 8 ++---
6 files changed, 39 insertions(+), 31 deletions(-)
rename t/{t1900-repo.sh => t1900-repo-info.sh} (100%)-- 2.50.1 (Apple Git-155)