git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCHv2 2/3] submodule-config: rename commit_sha1 to commit_or_tree

From
BWBrandon Williams <bmwill@google.com>
Date
Nov 22, 2016, 00:11 UTC
Message-ID
<20161122001148.GD149321@google.com>
In-Reply-To
<20161121232709.8906-3-sbeller@google.com>
On 11/21, Stefan Beller wrote:
Show 8 quoted lines
>  
>  	switch (lookup_type) {
> @@ -448,7 +448,8 @@ static const struct submodule *config_from(struct submodule_cache *cache,
>  
>  	/* fill the submodule config into the cache */
>  	parameter.cache = cache;
> -	parameter.commit_sha1 = commit_sha1;
> +	// todo: get the actual tree here:
s/todo/TODO
Makes it more clear that this is a TODO
-- 
Brandon Williams
Previous: Stefan BellerNext: Stefan Beller
Message 5 of 12 in “[PATCHv2 0/3] submodule-config: clarify/cleanup docs and header”
  1. Stefan BellerNov 21, 2016
  2. 1/3 submodule config: inline config_from_{name, path}Stefan Beller, Nov 21, 2016
  3. Junio C HamanoNov 22, 2016
  4. 2/3 submodule-config: rename commit_sha1 to commit_or_treeStefan Beller, Nov 21, 2016
  5. Brandon WilliamsNov 22, 2016
  6. Stefan BellerNov 22, 2016
  7. Brandon WilliamsNov 22, 2016
  8. Stefan BellerNov 22, 2016
  9. Junio C HamanoNov 22, 2016
  10. Stefan BellerNov 22, 2016
  11. 3/3 submodule-config: clarify parsing of null_sha1 elementStefan Beller, Nov 21, 2016
  12. Brandon WilliamsNov 22, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.