Re: [PATCH v6 3/6] verify-tag: change variable name for readability
- From
Jeff King <peff@peff.net>
- Date
- Apr 19, 2016, 05:13 UTC
- Message-ID
- <20160419051322.GB19439@sigill.intra.peff.net>
- In-Reply-To
- <1460932021-27633-4-git-send-email-santiago@nyu.edu>
On Sun, Apr 17, 2016 at 06:26:58PM -0400, santiago@nyu.edu wrote:
Show 16 quoted lines
> diff --git a/builtin/verify-tag.c b/builtin/verify-tag.c
> index 77f070a..010353c 100644
> --- a/builtin/verify-tag.c
> +++ b/builtin/verify-tag.c
> @@ -21,20 +21,21 @@ static const char * const verify_tag_usage[] = {
> static int run_gpg_verify(const char *buf, unsigned long size, unsigned flags)
> {
> struct signature_check sigc;
> - int len;
> + int payload_size;
> int ret;
>
> memset(&sigc, 0, sizeof(sigc));
>
> - len = parse_signature(buf, size);
> + payload_size = parse_signature(buf, size);While we're here, can we make payload_size a "size_t"? That is the return type of parse_signature.
> - if (size == len) {
> + if (size == payload_size) {That would make this a comparison between "unsigned long" and "size_t", but I doubt it would be the first such place in git. And it works out in practice, because "unsigned long" is generally at least as large as "size_t", and if our buffer is larger than "size_t" can store, we'd have failed long before, when trying to allocate the buffer.
We could make "size" also a "size_t", but I suspect then we'd just be bumping the mismatch out to its caller.
-Peff