Re: [PATCH v8 01/11] pkt-line: rename packet_write() to packet_write_fmt()
- From
Lars Schneider <larsxschneider@gmail.com>
- Date
- Sep 26, 2016, 18:49 UTC
- Message-ID
- <13E00B0F-41FC-4FBE-9ABD-2E9B11743E2B@gmail.com>
- In-Reply-To
- <592e18b7-ac2e-ed23-0321-57eb418d5172@gmail.com>
On 24 Sep 2016, at 23:14, Jakub Narębski <jnareb@gmail.com> wrote:
Show 23 quoted lines
> Hello Lars, > > W dniu 20.09.2016 o 21:02, larsxschneider@gmail.com pisze: > >> From: Lars Schneider <larsxschneider@gmail.com> >> >> packet_write() should be called packet_write_fmt() as the string >> parameter can be formatted. > > I would say: > > packet_write() should be called packet_write_fmt() because it > is printf-like function where first parameter is format string. > > Or something like that. But such minor change might be not worth > yet another reroll of this patch series. > > Perhaps it would be a good idea to explain the reasoning behind > this change: > > This is important distinction to know from the name if the > function accepts arbitrary binary data and/or arbitrary > strings to be written - packet_write[_fmt()] do not.
packet_write() should be called packet_write_fmt() because it is a printf-like function that takes a format string as first parameter.
packet_write_fmt() should be used for text strings only. Arbitrary binary data should use a new packet_write() function that is introduced in a subsequent patch.
Better?
Show 7 quoted lines
>> pkt-line.h | 2 +- >> shallow.c | 2 +- >> upload-pack.c | 30 +++++++++++++++--------------- >> 11 files changed, 29 insertions(+), 29 deletions(-) > > Diffstat looks correct. Was the patch generated by doing search > and replace?
Yes.
- Lars