threads / patch / 32674

v2INSTALL: git-p4 doesn't support Python 3

Subject: [PATCH v2] INSTALL: git-p4 doesn't support Python 3

## tl;dr

5 messages between Jan 20, 2013 and Jan 20, 2013. Diffs are folded; open one to read it.

replies: 4people: 3as markdown or json

John Keeping· Jan 20, 2013, 11:06 UTC · lore

git-p4 supports Python 2.6 and later versions of Python 2. Since Python 2.8 will never exist [1], it is most concise to just list the supported versions.

[1] http://www.python.org/dev/peps/pep-0404/
Signed-off-by: John Keeping <john@keeping.me.uk>
Acked-by: Pete Wyckoff <pw@padd.com>
---
Since v1:
 - Fixed a typo in the commit message.
 INSTALL | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Show changes to INSTALL +1 −1
diff --git a/INSTALL b/INSTALL
index 28f34bd..c456d1c 100644
--- a/INSTALL
+++ b/INSTALL
@@ -131,7 +131,7 @@ Issues of note:
 	  use English. Under autoconf the configure script will do this
 	  automatically if it can't find libintl on the system.
 
-	- Python version 2.6 or later is needed to use the git-p4
+	- Python version 2.6 or 2.7 is needed to use the git-p4
 	  interface to Perforce.
 
  - Some platform specific issues are dealt with Makefile rules,
-- 
1.8.1.353.gc992d5a.dirty
Junio C Hamano· Jan 20, 2013, 18:54 UTC · re: John Keeping · lore

Re: [PATCH v2] INSTALL: git-p4 doesn't support Python 3

John Keeping <john@keeping.me.uk> writes:
> git-p4 supports Python 2.6 and later versions of Python 2.  Since Python
> 2.8 will never exist [1], it is most concise to just list the supported
> versions.

Thanks; Eric's patch recently updated git-p4.py to require 2.4 I think. Shouldn't it also be updated?

Show 25 quoted lines
>
> [1] http://www.python.org/dev/peps/pep-0404/
>
> Signed-off-by: John Keeping <john@keeping.me.uk>
> Acked-by: Pete Wyckoff <pw@padd.com>
> ---
> Since v1:
>  - Fixed a typo in the commit message.
>
>  INSTALL | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/INSTALL b/INSTALL
> index 28f34bd..c456d1c 100644
> --- a/INSTALL
> +++ b/INSTALL
> @@ -131,7 +131,7 @@ Issues of note:
>  	  use English. Under autoconf the configure script will do this
>  	  automatically if it can't find libintl on the system.
>  
> -	- Python version 2.6 or later is needed to use the git-p4
> +	- Python version 2.6 or 2.7 is needed to use the git-p4
>  	  interface to Perforce.
>  
>   - Some platform specific issues are dealt with Makefile rules,
John Keeping· Jan 20, 2013, 19:28 UTC · re: Junio C Hamano · lore

Re: [PATCH v2] INSTALL: git-p4 doesn't support Python 3

On Sun, Jan 20, 2013 at 10:54:52AM -0800, Junio C Hamano wrote:
Show 8 quoted lines
> John Keeping <john@keeping.me.uk> writes:
> 
>> git-p4 supports Python 2.6 and later versions of Python 2.  Since Python
>> 2.8 will never exist [1], it is most concise to just list the supported
>> versions.
> 
> Thanks; Eric's patch recently updated git-p4.py to require 2.4 I
> think. Shouldn't it also be updated?

I haven't done a thorough audit to check what the actual minimum supported version is, this is just the minimal change to say "not Python 3".

Personally, I'm not sure of the value of having version checks at the top of the Python scripts, I would rather set a project-wide minimum supported version (as in my recent CodingGuidelines patch) and check it once in the Makefile.

John
Junio C Hamano· Jan 20, 2013, 19:54 UTC · re: John Keeping · lore

Re: [PATCH v2] INSTALL: git-p4 doesn't support Python 3

John Keeping <john@keeping.me.uk> writes:
Show 18 quoted lines
> On Sun, Jan 20, 2013 at 10:54:52AM -0800, Junio C Hamano wrote:
>> John Keeping <john@keeping.me.uk> writes:
>> 
>>> git-p4 supports Python 2.6 and later versions of Python 2.  Since Python
>>> 2.8 will never exist [1], it is most concise to just list the supported
>>> versions.
>> 
>> Thanks; Eric's patch recently updated git-p4.py to require 2.4 I
>> think. Shouldn't it also be updated?
>
> I haven't done a thorough audit to check what the actual minimum
> supported version is, this is just the minimal change to say "not
> Python 3".
>
> Personally, I'm not sure of the value of having version checks at the
> top of the Python scripts, I would rather set a project-wide minimum
> supported version (as in my recent CodingGuidelines patch) and check it
> once in the Makefile.

OK; I'll leave that for later a day (Cc'ed Eric but stakeholders of other Python scripts may want to express their opinions), and will apply this patch as is.

If we end up deciding to rip out the "prerequisite per file", that will be a tree-wide change that is independent from your patch we are discussing in this thread. If we end up not doing that, then we would instead be updating git-p4.py to set a higher floor to the prerequiste but that can come as a separate patch.

Thanks.
Brandon Casey· Jan 20, 2013, 21:03 UTC · re: John Keeping · lore

Re: [PATCH v2] INSTALL: git-p4 doesn't support Python 3

On Sun, Jan 20, 2013 at 11:28 AM, John Keeping <john@keeping.me.uk> wrote:
Show 9 quoted lines
> On Sun, Jan 20, 2013 at 10:54:52AM -0800, Junio C Hamano wrote:
>> John Keeping <john@keeping.me.uk> writes:
>>
>>> git-p4 supports Python 2.6 and later versions of Python 2.  Since Python
>>> 2.8 will never exist [1], it is most concise to just list the supported
>>> versions.
>>
>> Thanks; Eric's patch recently updated git-p4.py to require 2.4 I
>> think. Shouldn't it also be updated?

Actually, the script does not support python 2.4 in its current state since it uses subprocess.check_call which was introduced in python 2.5.

But, this can be trivially worked around. I made the changes in my own tree on Friday and planned to submit them after using it myself for a few days.

Personally, I prefer to continue to provide the ability to compile and
install a fully working git on platforms in common use without pulling
in additional dependencies.  At least while it's fairly easy to do so.
 So, in my opinion, git-p4 should be patched to support python 2.4 and
the comment in INSTALL should be updated.  But, this opinion should be
taken with the appropriate grain of salt since I'm not really a
contributor to any of the python infrastructure.
-Brandon

← back to recent threads