Re: [PATCH 1/4] t7601: test for pull.ff=true overrides merge.ff=false
- From
Junio C Hamano <gitster@pobox.com>
- Date
- May 14, 2015, 16:45 UTC
- Message-ID
- <xmqqy4kr85wg.fsf@gitster.dls.corp.google.com>
- In-Reply-To
- <2a5e49ff1cc3a0275e09328a3ad07866@www.dscho.org>
Johannes Schindelin <johannes.schindelin@gmx.de> writes:
Show 14 quoted lines
>> + verbose test "$(git rev-parse HEAD)" = "$(git rev-parse c1)"
>
> Given that Junio objected to this "verbose test", maybe you want to remove the "verbose"? Or introduce a `test_assert_equal` of the form
>
> ```sh
> test_assert_equal () {
> test "a$1" = "a$2" || {
> echo "$1 != $2" >&2
> false
> }
> }
> ```
>
> Hmm. Now that I think about it, `test_eq` is probably a better name, still.I do not think using "two strings" check for that one is very useful. You cannot tell where two 40-HEX came from.
And that is why I suggested "-i -v -x".
By the way, I cannot think of a reason why your CI cannot always run the tests with GIT_TEST_OPTS="-v -x" exported.
> For the sake of having better reporting, say, in Continuous Integration (where re-running tests via `sh -x t????-*.sh -i -v` -- as Junio suggested -- is not an option), I agree that it would be good to report the non-matching strings. > > Ciao, > Dscho