Re: [PATCH 1/4] t7601: test for pull.ff=true overrides merge.ff=false
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- May 14, 2015, 13:06 UTC
- Message-ID
- <2a5e49ff1cc3a0275e09328a3ad07866@www.dscho.org>
- In-Reply-To
- <1431510740-9710-2-git-send-email-pyokagan@gmail.com>
Hi,
On 2015-05-13 11:52, Paul Tan wrote:
Show 15 quoted lines
> diff --git a/t/t7601-merge-pull-config.sh b/t/t7601-merge-pull-config.sh > index f768c90..cef94e6 100755 > --- a/t/t7601-merge-pull-config.sh > +++ b/t/t7601-merge-pull-config.sh > @@ -45,6 +45,14 @@ test_expect_success 'fast-forward pull succeeds > with "true" in pull.ff' ' > test "$(git rev-parse HEAD)" = "$(git rev-parse c1)" > ' > > +test_expect_failure 'pull.ff=true overrides merge.ff=false' ' > + git reset --hard c0 && > + test_config merge.ff false && > + test_config pull.ff true && > + git pull . c1 && > + verbose test "$(git rev-parse HEAD)" = "$(git rev-parse c1)"
Given that Junio objected to this "verbose test", maybe you want to remove the "verbose"? Or introduce a `test_assert_equal` of the form
```sh
test_assert_equal () {
test "a$1" = "a$2" || {
echo "$1 != $2" >&2
false
}
}
```Hmm. Now that I think about it, `test_eq` is probably a better name, still.
For the sake of having better reporting, say, in Continuous Integration (where re-running tests via `sh -x t????-*.sh -i -v` -- as Junio suggested -- is not an option), I agree that it would be good to report the non-matching strings.
Ciao, Dscho