Re: [PATCH v2 2/4] t7401: change test_i18ncmp syntax for clarity
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 12, 2020, 21:02 UTC
- Message-ID
- <xmqqwo234lya.fsf@gitster.c.googlers.com>
- In-Reply-To
- <xmqq1rkb60ql.fsf@gitster.c.googlers.com>
Junio C Hamano <gitster@pobox.com> writes:
Show 24 quoted lines
> Shourya Shukla <shouryashukla.oo@gmail.com> writes: > >> Change the test_i18ncmp syntax from 'test_i18ncmp actual expected' to >> 'test_i18ncmp expected actual' to align it with the convention followed >> by other tests in the test script. >> ... >> @@ -285,7 +285,7 @@ EOF >> >> test_expect_success '--for-status' " >> git submodule summary --for-status HEAD^ >actual && >> - test_i18ncmp actual - <<EOF >> + test_i18ncmp - actual <<-EOF >> * sm1 $head6...0000000: >> >> * sm2 0000000...$head7 (2): > > This one does more than what the proposed log message explains, but > it does not do enough at the same time. > > If "actual vs expected order" is what this commit wants to fix, then > "<<EOF" vs "<<-EOF" is outside the scope of it. > > Personally, I think it is a good idea to update the end-of-heredoc > marker to "<<-EOF", ...
It seems that the theme of your [3/4] is exactly about fixing the "end-of-heredoc marker is prefixed with dash, but the heredoc is not indented for readability", so perhaps you'd want to stop this step at turning the line to
>> - test_i18ncmp actual - <<EOF >> + test_i18ncmp - actual <<EOF
i.e. "compare expected vs actual in this order", and then in the next patch [3/4], edit the line further to
test_i18ncmp - actual <<-EOF
*and* indent the here-doc at the same time?