From: Junio C Hamano Date: Wed, 12 Aug 2020 21:02:21 GMT Subject: Re: [PATCH v2 2/4] t7401: change test_i18ncmp syntax for clarity Message-ID: In-Reply-To: Junio C Hamano writes: > Shourya Shukla writes: > >> Change the test_i18ncmp syntax from 'test_i18ncmp actual expected' to >> 'test_i18ncmp expected actual' to align it with the convention followed >> by other tests in the test script. >> ... >> @@ -285,7 +285,7 @@ EOF >> >> test_expect_success '--for-status' " >> git submodule summary --for-status HEAD^ >actual && >> - test_i18ncmp actual - <> + test_i18ncmp - actual <<-EOF >> * sm1 $head6...0000000: >> >> * sm2 0000000...$head7 (2): > > This one does more than what the proposed log message explains, but > it does not do enough at the same time. > > If "actual vs expected order" is what this commit wants to fix, then > "< > Personally, I think it is a good idea to update the end-of-heredoc > marker to "<<-EOF", ... It seems that the theme of your [3/4] is exactly about fixing the "end-of-heredoc marker is prefixed with dash, but the heredoc is not indented for readability", so perhaps you'd want to stop this step at turning the line to >> - test_i18ncmp actual - <> + test_i18ncmp - actual <