Re: [PATCH 0/3] rev-list: add support for commits in `--missing`
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Oct 9, 2023, 22:02 UTC
- Message-ID
- <xmqqwmvvwj38.fsf@gitster.g>
- In-Reply-To
- <20231009105528.17777-1-karthik.188@gmail.com>
Karthik Nayak <karthik.188@gmail.com> writes:
Show 8 quoted lines
> This series is an alternate to the patch series I had posted earlier: > https://lore.kernel.org/git/20230908174208.249184-1-karthik.188@gmail.com/. > In that patch, we introduced an option `--ignore-missing-links` which > was added to expose the `ignore_missing_links` bit to the user. The > issue in that patch was that, the option `--ignore-missing-links` didn't > play well the pre-existing `--missing` option. This series avoids that > route and just extends the `--missing` option for commits to solve the > same problem.
Thanks for exploring the problem space in the other direction.
I haven't really thought things through yet, but it looks to me that the updated behaviour of "--missing" is more in line with what the option would have wanted to be from day one.
Show 14 quoted lines
> Karthik Nayak (3): > revision: rename bit to `do_not_die_on_missing_objects` > rev-list: move `show_commit()` to the bottom > rev-list: add commit object support in `--missing` option > > builtin/reflog.c | 2 +- > builtin/rev-list.c | 93 +++++++++++++++++++------------------ > list-objects.c | 2 +- > object.h | 2 +- > revision.c | 9 +++- > revision.h | 20 ++++---- > t/t6022-rev-list-missing.sh | 74 +++++++++++++++++++++++++++++ > 7 files changed, 145 insertions(+), 57 deletions(-) > create mode 100755 t/t6022-rev-list-missing.sh