Re: [PATCH v2 00/20] Stop using `the_repository` in "config.c"
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 13, 2024, 17:07 UTC
- Message-ID
- <xmqqwmkk5p2p.fsf@gitster.g>
- In-Reply-To
- <cover.1723540226.git.ps@pks.im>
Patrick Steinhardt <ps@pks.im> writes:
Show 18 quoted lines
> this is the second version of my patch series that drops the dependency > on `the_repository` in both "path.c" and "config.c". > > Changes compared to v1: > > - Various typo fixes in commit messages. > > - Rename `strbuf_git_common_pathv()` to `repo_common_pathv()`. > > - Reorder arguments of `strbuf_edit_interactively()` such that the > `struct repository` gets passed as first argument. > > - Document behaviour of `worktree_git_path()` when no worktree is > given. > > - Wrap some overly long lines. > > Thanks!
Nicely done. I found that both of the two larger changes relative to the previous iteration are sensible.