Re: [PATCH v2 00/20] Stop using `the_repository` in "config.c"
- From
Justin Tobler <jltobler@gmail.com>
- Date
- Aug 15, 2024, 00:58 UTC
- Message-ID
- <doivvzjzsrxngrafcywfxbs355epthuxdu5x3kxe2mvwnzgpf5@pgotr3bbyb4u>
- In-Reply-To
- <cover.1723540226.git.ps@pks.im>
On 24/08/13 11:13AM, Patrick Steinhardt wrote:
Show 20 quoted lines
> Hi, > > this is the second version of my patch series that drops the dependency > on `the_repository` in both "path.c" and "config.c". > > Changes compared to v1: > > - Various typo fixes in commit messages. > > - Rename `strbuf_git_common_pathv()` to `repo_common_pathv()`. > > - Reorder arguments of `strbuf_edit_interactively()` such that the > `struct repository` gets passed as first argument. > > - Document behaviour of `worktree_git_path()` when no worktree is > given. > > - Wrap some overly long lines. > > Thanks!
After reviewing the changes in this version, the series looks good to me! Thanks :)
-Justin