Re: [PATCH v5 00/11] add performance tracing facility
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jun 12, 2014, 18:30 UTC
- Message-ID
- <xmqqvbs656bu.fsf@gitster.dls.corp.google.com>
- In-Reply-To
- <53980B83.9050409@gmail.com>
Karsten Blees <karsten.blees@gmail.com> writes:
Show 15 quoted lines
> Here's v5 of the performance tracing patch series, now including a bunch of cleanups and adding timestamp, file and line to all trace output. > > I'm particularly interested in feedback for the output format. As file names have different lengths, printing file:line as prefix results in unaligned output: > > > GIT_TRACE=1 git stash list > 00:12:10.544266 git.c:512 trace: exec: 'git-stash' 'list' > 00:12:10.544266 run-command.c:337 trace: run_command: 'git-stash' 'list' > 00:12:10.649779 git.c:312 trace: built-in: git 'rev-parse' '--git-dir' > > We could add separators to make it easier to parse, e.g.: > > > GIT_TRACE=1 git stash list > [00:12:10.544266 git.c:512] trace: exec: 'git-stash' 'list' > [00:12:10.544266 run-command.c:337] trace: run_command: 'git-stash' 'list' > [00:12:10.649779 git.c:312] trace: built-in: git 'rev-parse' '--git-dir'
This is easier to parse if " " and ":" are found in the names of _our_ source files and "]" isn't, but is that really the case?
> Or print file:line at the end (but what about multi-line messages, such as packet-trace?): > > > GIT_TRACE=1 git stash list > 00:12:10.544266 trace: exec: 'git-stash' 'list' (git.c:512)
Somehow I find this a lot harder to read than the other two.
I am not commenting on the usefulness of the patch series (yet), though.
-- -- *** Please reply-to-all at all times *** *** (do not pretend to know who is subscribed and who is not) *** *** Please avoid top-posting. *** The msysGit Wiki is here: https://github.com/msysgit/msysgit/wiki - Github accounts are free. You received this message because you are subscribed to the Google Groups "msysGit" group. To post to this group, send email to msysgit@googlegroups.com To unsubscribe from this group, send email to msysgit+unsubscribe@googlegroups.com For more options, and view previous threads, visit this group at http://groups.google.com/group/msysgit?hl=en_US?hl=en --- You received this message because you are subscribed to the Google Groups "msysGit" group. To unsubscribe from this group and stop receiving emails from it, send an email to msysgit+unsubscribe@googlegroups.com. For more options, visit https://groups.google.com/d/optout.