Re: [PATCH 00/10] config-hook cleanups and two small 'git hook list' features
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Mar 9, 2026, 20:27 UTC
- Message-ID
- <xmqqsea84uk5.fsf@gitster.g>
- In-Reply-To
- <20260309005416.2760030-1-adrian.ratiu@collabora.com>
Adrian Ratiu <adrian.ratiu@collabora.com> writes:
Show 10 quoted lines
> Hello everyone, > > As promised I've spun-off v3 of the config series [1] into its own standalone > patch series after v2 landed in next. > > This is mostly minor cleanups and refactorings + two minor feature additions > to `git hook list`, which resulted from the previous review discussions: > > 1. The ability to show the config scope (--show-scope). > 2. The ability to show which hooks are disabled.
This is a very pleasant series to read. Thank you for spinning these cleanups and new features off into their own series. It makes the evolution of the hook-config work much easier to follow.
The overall progression from general cleanups to the more involved cache refactoring and finally the new features is logical and well- executed.
I may have a few comments on the later patches, but the early parts look already very promising.
[PATCH 1/10] to [PATCH 4/10] These look solid and correctly address the style and naming nits raised in previous rounds. Moving unsorted_string_list_remove() to string-list.[ch] is a good call as it's a generally useful utility.
[PATCH 5/10] hook: replace hook_list_clear() -> string_list_clear_func() Appreciative of this change; using the standard string_list API makes the code more idiomatic. Stashing the data_free pointer in struct hook is a clean way to handle the internal callback data.
Thanks.