Re: [PATCH 14/22] test-lib functions: add --author support to test_commit
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jan 12, 2021, 22:34 UTC
- Message-ID
- <xmqqr1mp23a2.fsf@gitster.c.googlers.com>
- In-Reply-To
- <20210112201806.13284-15-avarab@gmail.com>
Ævar Arnfjörð Bjarmason <avarab@gmail.com> writes:
Show 6 quoted lines
> Add support for --author to "test_commit". This will simplify some > current and future tests, one of those is being changed here. > > Let's also line-wrap the "git commit" command invocation to make diffs > that add subsequent options easier to add, as they'll only need to add > a new option line.
Makes sense.
> - git commit -m "Initial Commit" --author Frigate\ \<flying@over.world\> && > - git tag Initial && > + test_commit --author Frigate\ \<flying@over.world\> \ > + "Initial Commit" foo Initial Initial &&
Why not fix the value of the author while at it to be more readable? E.g. --author "Frigate <flying@over.world>"