From: Junio C Hamano Date: Tue, 12 Jan 2021 22:34:13 GMT Subject: Re: [PATCH 14/22] test-lib functions: add --author support to test_commit Message-ID: In-Reply-To: <20210112201806.13284-15-avarab@gmail.com> Ævar Arnfjörð Bjarmason writes: > Add support for --author to "test_commit". This will simplify some > current and future tests, one of those is being changed here. > > Let's also line-wrap the "git commit" command invocation to make diffs > that add subsequent options easier to add, as they'll only need to add > a new option line. Makes sense. > - git commit -m "Initial Commit" --author Frigate\ \ && > - git tag Initial && > + test_commit --author Frigate\ \ \ > + "Initial Commit" foo Initial Initial && Why not fix the value of the author while at it to be more readable? E.g. --author "Frigate "