Re: [PATCH v2 1/3] Move init_skiplist() outside of fsck
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jan 22, 2019, 17:54 UTC
- Message-ID
- <xmqqpnsoh92x.fsf@gitster-ct.c.googlers.com>
- In-Reply-To
- <87ef953tyn.fsf@evledraar.gmail.com>
Ævar Arnfjörð Bjarmason <avarab@gmail.com> writes:
> It needing to be bidirectional is a very good point, and I think that > makes my suggestion a non-starter. Thanks.
Yes, it is a bit sad that we need to carry the mistakes forward while moving to the new hash, but bidi convertibility is a must for the transition to work smoothly, I think.
Thanks for a good discussion. FWIW, on the original issue that brought it up, I think using "object name" from the glossary to move away from saying "SHA-1" would be good.