git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2] doc: camelCase the config variables to improve readability

From
Junio C Hamano <gitster@pobox.com>
Date
Sep 24, 2017, 00:28 UTC
Message-ID
<xmqqmv5lhre2.fsf@gitster.mtv.corp.google.com>
In-Reply-To
<20170923045617.3782-1-kaarticsivaraam91196@gmail.com>
Kaartic Sivaraam <kaarticsivaraam91196@gmail.com> writes:
Show 8 quoted lines
> A few configuration variable names of Git are composite words. References
> to such variables in manpages are hard to read because they use all-lowercase
> names, without indicating where each word ends and begins.
>
> Improve its readability by using camelCase instead.  Git treats these
> names case-insensitively so this does not affect functionality. This
> also ensures consistency with other parts of the docs that use camelCase
> fo refer to configuration variable names.
s/fo/to/ (or s/fo/in order to/)?  

I think the one I have on 'pu' uses Jonathan's suggested rewrite of the log message verbatim, and I suspect that it is already clear enough, even though I admit that I stuttered a bit while reading its first sentence.

I'd avoid "A few" above, as it is my impression that we use multi-word names quite a bit, not just a few.

Perhaps
	References to multi-word configuration variable names in our
	documentation must consistently use camelCase to highlight
	where the word boundaries are, even though these are treated
	case insensitively.
	Fix a few places that spell them in all lowercase, which
	makes them harder to read.

may be a more succinct way to say the same thing. We state the rule upfront, explain what the rule is for, and tell the codebase to apply the rule. That should cover everything your version and Jonathan's version wanted to convey, I'd think.

Previous: Kaartic SivaraamNext: Kaartic Sivaraam
Message 5 of 7 in “doc: camelCase the config variables to improve readability”
  1. doc: camelCase the config variables to improve readabilityKaartic Sivaraam, Sep 19, 2017
  2. Jonathan NiederSep 19, 2017
  3. Kaartic SivaraamSep 20, 2017
  4. doc: camelCase the config variables to improve readabilityKaartic Sivaraam, Sep 23, 2017
  5. Junio C HamanoSep 24, 2017
  6. Kaartic SivaraamSep 24, 2017
  7. doc: camelCase the config variables to improve readabilityKaartic Sivaraam, Sep 25, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.