Re: [PATCH] doc: camelCase the config variables to improve readability
- From
Jonathan Nieder <jrnieder@gmail.com>
- Date
- Sep 19, 2017, 20:22 UTC
- Message-ID
- <20170919202201.GD75068@aiede.mtv.corp.google.com>
- In-Reply-To
- <0102015e9a2d3eb6-bee76ba8-4298-47d2-8822-d513bc33bd71-000000@eu-west-1.amazonses.com>
Hi,
Kaartic Sivaraam wrote:
> The config variable used weren't readable as they were in the > crude form of how git stores/uses it's config variables.
nit: Git's commit messages describe the current behavior of Git in the present tense. Something like:
These manpages' references to config variables are hard to read because they use all-lowercase names, without indicating where each word ends and begins in the configuration variable names.
Improve readability by using camelCase instead. Git treats these names case-insensitively so this does not affect functionality.
> Improve it's readability by replacing them with camelCased versions > of config variables as it doesn't have any impact on it's usage.
nit: s/it's/its/ (in both places)
Show 5 quoted lines
> Signed-off-by: Kaartic Sivaraam <kaarticsivaraam91196@gmail.com> > --- > Documentation/git-branch.txt | 4 ++-- > Documentation/git-tag.txt | 2 +- > 2 files changed, 3 insertions(+), 3 deletions(-)
This also is just more consistent with the rest of the docs.
FWIW, with or without the commit message tweaks mentioned above, Reviewed-by: Jonathan Nieder <jrnieder@gmail.com>
Thanks for your attention to detail.