Re: [PATCH v2] doc: camelCase the config variables to improve readability
- From
Kaartic Sivaraam <kaarticsivaraam91196@gmail.com>
- Date
- Sep 24, 2017, 05:21 UTC
- Message-ID
- <1506230463.2425.2.camel@gmail.com>
- In-Reply-To
- <xmqqmv5lhre2.fsf@gitster.mtv.corp.google.com>
On Sun, 2017-09-24 at 09:28 +0900, Junio C Hamano wrote:
Show 13 quoted lines
> Kaartic Sivaraam <kaarticsivaraam91196@gmail.com> writes: > > > A few configuration variable names of Git are composite words. References > > to such variables in manpages are hard to read because they use all-lowercase > > names, without indicating where each word ends and begins. > > > > Improve its readability by using camelCase instead. Git treats these > > names case-insensitively so this does not affect functionality. This > > also ensures consistency with other parts of the docs that use camelCase > > fo refer to configuration variable names. > > s/fo/to/ (or s/fo/in order to/)? >
Yeah, a typo that I missed.
Show 15 quoted lines
> Perhaps > > References to multi-word configuration variable names in our > documentation must consistently use camelCase to highlight > where the word boundaries are, even though these are treated > case insensitively. > > Fix a few places that spell them in all lowercase, which > makes them harder to read. > > may be a more succinct way to say the same thing. We state the rule > upfront, explain what the rule is for, and tell the codebase to > apply the rule. That should cover everything your version and > Jonathan's version wanted to convey, I'd think. >
Much better, thanks. Will resend with this updated message.
--- Kaartic