git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v3] doc: camelCase the config variables to improve readability

From
Kaartic Sivaraam <kaartic.sivaraam@gmail.com>
Date
Sep 25, 2017, 08:27 UTC
Message-ID
<20170925082747.3171-1-kaarticsivaraam91196@gmail.com>
In-Reply-To
<xmqqmv5lhre2.fsf@gitster.mtv.corp.google.com>

References to multi-word configuration variable names in our documentation must consistently use camelCase to highlight where the word boundaries are, even though these are treated case insensitively.

Fix a few places that spell them in all lowercase, which makes them harder to read.

Signed-off-by: Kaartic Sivaraam <kaarticsivaraam91196@gmail.com>
Reviewed-by: Jonathan Nieder <jrnieder@gmail.com>
---
 Changes in v3:
    - Used the commit message as suggested by Junio
 Documentation/git-branch.txt | 4 ++--
 Documentation/git-tag.txt    | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/Documentation/git-branch.txt b/Documentation/git-branch.txt
index e292737b9..58f1e5c9c 100644
--- a/Documentation/git-branch.txt
+++ b/Documentation/git-branch.txt
@@ -92,10 +92,10 @@ OPTIONS
 	all changes made to the branch ref, enabling use of date
 	based sha1 expressions such as "<branchname>@\{yesterday}".
 	Note that in non-bare repositories, reflogs are usually
-	enabled by default by the `core.logallrefupdates` config option.
+	enabled by default by the `core.logAllRefUpdates` config option.
 	The negated form `--no-create-reflog` only overrides an earlier
 	`--create-reflog`, but currently does not negate the setting of
-	`core.logallrefupdates`.
+	`core.logAllRefUpdates`.
 
 -f::
 --force::
diff --git a/Documentation/git-tag.txt b/Documentation/git-tag.txt
index 543fb425e..95e9f391d 100644
--- a/Documentation/git-tag.txt
+++ b/Documentation/git-tag.txt
@@ -174,7 +174,7 @@ This option is only applicable when listing tags without annotation lines.
 	`core.logAllRefUpdates` in linkgit:git-config[1].
 	The negated form `--no-create-reflog` only overrides an earlier
 	`--create-reflog`, but currently does not negate the setting of
-	`core.logallrefupdates`.
+	`core.logAllRefUpdates`.
 
 <tagname>::
 	The name of the tag to create, delete, or describe.
-- 
2.14.1.539.g78797280a.dirty
Previous: Kaartic Sivaraam
Message 7 of 7 in “doc: camelCase the config variables to improve readability”
  1. doc: camelCase the config variables to improve readabilityKaartic Sivaraam, Sep 19, 2017
  2. Jonathan NiederSep 19, 2017
  3. Kaartic SivaraamSep 20, 2017
  4. doc: camelCase the config variables to improve readabilityKaartic Sivaraam, Sep 23, 2017
  5. Junio C HamanoSep 24, 2017
  6. Kaartic SivaraamSep 24, 2017
  7. doc: camelCase the config variables to improve readabilityKaartic Sivaraam, Sep 25, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.