Re: [PATCH v6 0/6] status: show default branch comparison when tracking non-default branch
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Dec 25, 2025, 08:00 UTC
- Message-ID
- <xmqqms37m1n9.fsf@gitster.g>
- In-Reply-To
- <pull.2138.v6.git.git.1766619672.gitgitgadget@gmail.com>
"Harald Nordgren via GitGitGadget" <gitgitgadget@gmail.com> writes:
Show 10 quoted lines
> cc: Chris Torek chris.torek@gmail.com cc: Yee Cheng Chin > ychin.macvim@gmail.com cc: "brian m. carlson" sandals@crustytoothpaste.net > > Harald Nordgren (6): > status: show comparison with upstream default branch > Simplify default branch comparison logic > Use repo.settings.statusGoalBranch config for status comparison > Rename default_remote to goal_branch > Add warning for malformed statusGoalBranch config > Change config key to status.compareBranch
It seems that [v6 6/6] smells like an "oops, what I did in [v6 3/6] was wrong, and this is an incremental fix on top of it".
Please don't.
When presenting your topic to the list, rather, after you finish a series and the end result reaches a satisfactory state, please look back and polish patches to hide such mistakes in the middle, pretend as if you are a perfect developer who wrote a logical progression of patches that goes straight to the goal without stumbling around, taking detours, and making mistakes you need to correct in a later step. Detours may have been taken when you initially wrote the series, and it may show the "true history" from your point of view, but to others (and the most importantly, to those who read "git log -p" later in order to extend your work to suit their needs better), they are merely distracting.
The titles in [2-6/6] by the way do not seem to follow the established convention, like [1/6] does, i.e. "status: show comparison...", use an area prefix "<area>:", followed by a short-summary that is not capitalized.
Thanks.