Re: [PATCH 01/14] cmd_{read,write}_tree: rename "unused" variable that is used
- From
Junio C Hamano <gitster@pobox.com>
- Date
- May 13, 2019, 05:14 UTC
- Message-ID
- <xmqqlfzbc4wo.fsf@gitster-ct.c.googlers.com>
- In-Reply-To
- <20190509212724.GA15837@sigill.intra.peff.net>
Jeff King <peff@peff.net> writes:
> I kind of hate "cmd_prefix"; I was tempted to just call it "prefix" so > that all of the cmd_* functions were consistent, but I worried that it > really would get confused with the local variables (even if those > variables are renamed, as I do here).
I tend to agree with your temptation to make things consisten, especially because you already do the renaming of existing "prefix" to "tree_prefix".
Perhaps in a few release cycles, these can be renamed again to be consistent with everybody else, and I won't die if this were called cmd_prefix until then ;-)