Re: [PATCH v3 3/4] fetch-pack: expose fsckObjects configuration logic
- From
Junio C Hamano <gitster@pobox.com>
- Date
- May 28, 2024, 17:10 UTC
- Message-ID
- <xmqqikyx6ew9.fsf@gitster.g>
- In-Reply-To
- <ZlXIBrs5Q91r_-qU@tanuki>
Patrick Steinhardt <ps@pks.im> writes:
Show 22 quoted lines
>> +int fetch_pack_fsck_objects(void)
>> +{
>> + fetch_pack_setup();
>> +
>> + return fetch_fsck_objects >= 0
>> + ? fetch_fsck_objects
>> + : transfer_fsck_objects >= 0
>> + ? transfer_fsck_objects
>> + : 0;
>> +}
>
> ... can we maybe rewrite it to something more customary here? The
> following is way easier to read, at least for me.
>
> int fetch_pack_fsck_objects(void)
> {
> fetch_pack_setup();
> if (fetch_fsck_objects >= 0 ||
> transfer_fsck_objects >= 0)
> return 1;
> return 0;
> }But do they mean the same thing? In a repository where
[fetch] fsckobjects = no
is set, no matter what transfer.fsckobjects says (or left unspecified), we want to return "no, we are not doing fsck".