Re: [PATCH v6 2/3] fetch-pack: expose fsckObjects configuration logic
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jun 11, 2024, 19:20 UTC
- Message-ID
- <xmqq5xufuw09.fsf@gitster.g>
- In-Reply-To
- <d21c236b8dec9fd8c81a4224c1f63c511b04d8b9.1718109943.git.gitgitgadget@gmail.com>
"Xing Xin via GitGitGadget" <gitgitgadget@gmail.com> writes:
Show 11 quoted lines
> - if (fetch_fsck_objects >= 0
> - ? fetch_fsck_objects
> - : transfer_fsck_objects >= 0
> - ? transfer_fsck_objects
> - : 0)
> - fsck_objects = 1;
> + fsck_objects = fetch_pack_fsck_objects();
> ...
> +int fetch_pack_fsck_objects(void)
> +{
> + fetch_pack_setup();OK, this one is designed to be as lightweight as possible when it has already been called, so a potentially duplicated call would not cause too much worries here.
Show 6 quoted lines
> + if (fetch_fsck_objects >= 0) > + return fetch_fsck_objects; > + if (transfer_fsck_objects >= 0) > + return transfer_fsck_objects; > + return 0; > +}
Much easier to follow. Nicely done.