Re: [PATCH 1/6] add, update-index: fix --chmod argument help
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 2, 2018, 21:17 UTC
- Message-ID
- <xmqqeffgzcw5.fsf@gitster-ct.c.googlers.com>
- In-Reply-To
- <4b6fa9ca-97ad-74e8-f252-cc62470f5946@ramsayjones.plus.com>
Ramsay Jones <ramsay@ramsayjones.plus.com> writes:
Show 5 quoted lines
>> OPT_BOOL( 0 , "ignore-missing", &ignore_missing, N_("check if - even missing - files are ignored in dry run")),
>> - OPT_STRING( 0 , "chmod", &chmod_arg, N_("(+/-)x"), N_("override the executable bit of the listed files")),
>> + { OPTION_STRING, 0, "chmod", &chmod_arg, "(+|-)x",
>
> Am I alone in thinking that "(+x|-x)" is more readable?I think I am guilty of that, and I agree yours is much easier to read.
It can of course come on top of the series.