Re: [PATCH v2] test_must_be_empty: simplify file existence check
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Mar 28, 2018, 00:10 UTC
- Message-ID
- <xmqqd0zp9i0d.fsf@gitster-ct.c.googlers.com>
- In-Reply-To
- <20180326131124.13003-1-szeder.dev@gmail.com>
SZEDER Gábor <szeder.dev@gmail.com> writes:
Show 32 quoted lines
> Commit 11395a3b4b (test_must_be_empty: make sure the file exists, not
> just empty, 2018-02-27) basically duplicated the 'test_path_is_file'
> helper function in 'test_must_be_empty'.
>
> Just call 'test_path_is_file' to avoid this code duplication.
>
> Signed-off-by: SZEDER Gábor <szeder.dev@gmail.com>
> ---
>
> The only change is to refer to the right commit in the log message.
>
> t/test-lib-functions.sh | 7 ++-----
> 1 file changed, 2 insertions(+), 5 deletions(-)
>
> diff --git a/t/test-lib-functions.sh b/t/test-lib-functions.sh
> index d2eaf5ab67..36ad8accdd 100644
> --- a/t/test-lib-functions.sh
> +++ b/t/test-lib-functions.sh
> @@ -718,11 +718,8 @@ verbose () {
> # otherwise.
>
> test_must_be_empty () {
> - if ! test -f "$1"
> - then
> - echo "'$1' is missing"
> - return 1
> - elif test -s "$1"
> + test_path_is_file "$1" &&
> + if test -s "$1"
> then
> echo "'$1' is not empty, it contains:"
> cat "$1""Just call it" is fine as an idea but
A && if B then ... fi
is somewhat questionable. Shouldn't we make it
if A && B then ... fi
instead? That way, if we ever need to add an else clause, the logic flow would be more obvious, no?