Re: [PATCH] test_must_be_empty: simplify file existence check
- From
Jeff King <peff@peff.net>
- Date
- Mar 26, 2018, 12:48 UTC
- Message-ID
- <20180326124847.GA21993@sigill.intra.peff.net>
- In-Reply-To
- <20180326115815.10180-1-szeder.dev@gmail.com>
On Mon, Mar 26, 2018 at 01:58:15PM +0200, SZEDER Gábor wrote:
Show 5 quoted lines
> Commit ea3c87d0b7 (test_must_be_empty: make sure the file exists, not > just empty, 2018-02-27) basically duplicated the 'test_path_is_file' > helper function in 'test_must_be_empty'. > > Just call 'test_path_is_file' to avoid this code duplication.
This looks like an improvement to me.
I think you meant to reference 11395a3b4b16d9fc637ca2e41a6892ea2e6289ce, though (I don't have ea3c87d0b7 at all).
-Peff