Re: [PATCH] test_must_be_empty: simplify file existence check
- From
SZEDER Gábor <szeder.dev@gmail.com>
- Date
- Mar 26, 2018, 13:09 UTC
- Message-ID
- <CAM0VKjmCNDAKF=ueDBtscTUMJzVEZoFDA_CO6Oz9sTLUpyyiuQ@mail.gmail.com>
- In-Reply-To
- <20180326124847.GA21993@sigill.intra.peff.net>
On Mon, Mar 26, 2018 at 2:48 PM, Jeff King <peff@peff.net> wrote:
Show 12 quoted lines
> On Mon, Mar 26, 2018 at 01:58:15PM +0200, SZEDER Gábor wrote: > >> Commit ea3c87d0b7 (test_must_be_empty: make sure the file exists, not >> just empty, 2018-02-27) basically duplicated the 'test_path_is_file' >> helper function in 'test_must_be_empty'. >> >> Just call 'test_path_is_file' to avoid this code duplication. > > This looks like an improvement to me. > > I think you meant to reference 11395a3b4b16d9fc637ca2e41a6892ea2e6289ce, > though (I don't have ea3c87d0b7 at all).
Indeed. I remember picking up that patch from the mailing list, which then became ea3c87d0b7 in my repo. What I don't remember is how I managed to build on top of this hand-picked commit instead of what has been in git.git for a month...