[PATCH] test_must_be_empty: simplify file existence check
- From
SZEDER Gábor <szeder.dev@gmail.com>
- Date
- Mar 26, 2018, 11:58 UTC
- Message-ID
- <20180326115815.10180-1-szeder.dev@gmail.com>
Commit ea3c87d0b7 (test_must_be_empty: make sure the file exists, not just empty, 2018-02-27) basically duplicated the 'test_path_is_file' helper function in 'test_must_be_empty'.
Just call 'test_path_is_file' to avoid this code duplication.
Signed-off-by: SZEDER Gábor <szeder.dev@gmail.com> --- t/test-lib-functions.sh | 7 ++----- 1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/t/test-lib-functions.sh b/t/test-lib-functions.sh index d2eaf5ab67..36ad8accdd 100644 --- a/t/test-lib-functions.sh +++ b/t/test-lib-functions.sh @@ -718,11 +718,8 @@ verbose () { # otherwise. test_must_be_empty () { - if ! test -f "$1" - then - echo "'$1' is missing" - return 1 - elif test -s "$1" + test_path_is_file "$1" && + if test -s "$1" then echo "'$1' is not empty, it contains:" cat "$1"
-- 2.17.0.rc1.145.gfac1bf9500