Re: [PATCH v3 2/4] real_path: convert real_path_internal to strbuf_realpath
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Dec 12, 2016, 22:20 UTC
- Message-ID
- <xmqq8trk94ck.fsf@gitster.mtv.corp.google.com>
- In-Reply-To
- <1481566615-75299-3-git-send-email-bmwill@google.com>
Brandon Williams <bmwill@google.com> writes:
Show 5 quoted lines
> Change the name of real_path_internal to strbuf_realpath. In addition > push the static strbuf up to its callers and instead take as a > parameter a pointer to a strbuf to use for the final result. > > This change makes strbuf_realpath reentrant.
Yup, this step makes sense.