From: Junio C Hamano Date: Mon, 12 Dec 2016 22:20:43 GMT Subject: Re: [PATCH v3 2/4] real_path: convert real_path_internal to strbuf_realpath Message-ID: In-Reply-To: <1481566615-75299-3-git-send-email-bmwill@google.com> Brandon Williams writes: > Change the name of real_path_internal to strbuf_realpath. In addition > push the static strbuf up to its callers and instead take as a > parameter a pointer to a strbuf to use for the final result. > > This change makes strbuf_realpath reentrant. Yup, this step makes sense.