Re: [PATCH v7 1/6] t5323: test cases for git-pack-redundant
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jan 31, 2019, 21:44 UTC
- Message-ID
- <xmqq7eek1ozm.fsf@gitster-ct.c.googlers.com>
- In-Reply-To
- <20190130114736.30357-2-worldhello.net@gmail.com>
Jiang Xin <worldhello.net@gmail.com> writes:
Show 21 quoted lines
> diff --git a/t/t5323-pack-redundant.sh b/t/t5323-pack-redundant.sh
> new file mode 100755
> index 0000000000..710fe9884c
> --- /dev/null
> +++ b/t/t5323-pack-redundant.sh
> @@ -0,0 +1,322 @@
> +#!/bin/sh
> +#
> +# Copyright (c) 2018 Jiang Xin
> +#
> +
> +test_description='git pack-redundant test'
> +
> +. ./test-lib.sh
> +
> +create_commits () {
> + parent=
> + for name in A B C D E F G H I J K L M N O P Q R
> + do
> + test_tick &&
> + T=$(git write-tree) &&Move this outside loop, not for efficiency but for clarity. This helper function creates a single empty tree and bunch of commits that hold the same empty tree, arranged as a single strand of pearls.
By the way, I had to draw a table like this to figure out ...
T A B C D E F G H I J K L M N O P Q R 1 x x x x x x x x 2 x x x x x x x 3 x x x x x x 4 x x x x x 5 x x x x 6 x x x 7 x x 8 x
... what is going on. Perhaps something like this would help other readers near the top of the file (or in test_description)?
Show 10 quoted lines
> +format_packfiles () {
> + sed \
> + -e "s#.*/pack-\(.*\)\.idx#\1#" \
> + -e "s#.*/pack-\(.*\)\.pack#\1#" |
> + sort -u |
> + while read p
> + do
> + if test -z "$(eval echo \${P$p})"
> + then
> + echo $pAll the "expected output" below will expect P$n:${P$n} prepared by various create_pack_$n helpers we saw earlier, so an unknown packfile would be detected as a line that this emits. Is that the idea?
Show 12 quoted lines
> + else
> + eval echo "\${P$p}"
> + fi
> + done |
> + sort
> +}
> +
> +test_expect_success 'setup master.git' '
> + git init --bare master.git &&
> + cd master.git &&
> + create_commits
> +'Everything below will be done inside master.git? Avoid cd'ing around in random places in the test script, as a failure in any of the steps that does cd would start later tests in an unexpected place, if you can.
Show 10 quoted lines
> +test_expect_success 'no redundant for pack 1, 2, 3' ' > + create_pack_1 && create_pack_2 && create_pack_3 && > + git pack-redundant --all >out && > + test_must_be_empty out > +' > + > +test_expect_success 'create pack 4, 5' ' > + create_pack_4 && create_pack_5 > +' > +
Show 9 quoted lines
> +cat >expected <<EOF > +P2:$P2 > +EOF > + > +test_expect_success 'one of pack-2/pack-3 is redundant' ' > + git pack-redundant --all >out && > + format_packfiles <out >actual && > + test_cmp expected actual > +'
Do the preparation of file "expect" (most of the tests compare 'expect' vs 'actual', not 'expected') _inside_ the next test that uses it. i.e.
test_expect_success 'with 1 4 and 5, either 2 or 3 can be omitted' ' cat >expect <<-EOF && P2:$P2 EOF git pack-redundant --all >out && format ... >actual && test_cmp expect actual '
Again, I needed to draw this to see if the "one of ... is redundant" in the title is a valid claim. Something like it would help future readers.
T A B C D E F G H I J K L M N O P Q R 1245 x x x x x x x x x x x x x x x x x 3 x x x x x x
T A B C D E F G H I J K L M N O P Q R 1345 x x x x x x x x x x x x x x x x x 2 x x x x x x x
I won't repeat the same for tests that appear later in this file, but they share the same issue.
> +test_expect_success 'setup shared.git' ' > + cd "$TRASH_DIRECTORY" && > + git clone -q --mirror master.git shared.git &&
Why "-q"?
> + cd shared.git && > + printf "../../master.git/objects" >objects/info/alternates > +'
Why not echo? I recall designing the alternates file to be a plain text file. Is it necessary to leave the line incomplete?
> +test_expect_success 'remove redundant packs by alt-odb, no packs left' ' > + git pack-redundant --all --alt-odb | xargs rm && > + git fsck --no-progress &&
Why "--no-progress"?
Show 6 quoted lines
> + test_must_fail git pack-redundant --all --alt-odb >actual 2>&1 &&
> + test_cmp expected actual
> +'
> +
> +create_commits_others () {
> + parent=$(git rev-parse HEAD)If this fails, you'd still go ahead and enter the loop, which is not what you want.
> + for name in X Y Z > + do > + test_tick && > + T=$(git write-tree) &&
Lift this outside the loop.
Show 12 quoted lines
> + if test -z "$parent" > + then > + oid=$(echo $name | git commit-tree $T) > + else > + oid=$(echo $name | git commit-tree -p $parent $T) > + fi && > + eval $name=$oid && > + parent=$oid || > + return 1 > + done > + git update-ref refs/heads/master $Z > +}