git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [RFC/PATCH 1/9] tag: libify parse_opt_points_at()

From
Junio C Hamano <gitster@pobox.com>
Date
Jun 8, 2015, 19:00 UTC
Message-ID
<xmqq4mmiauu0.fsf@gitster.dls.corp.google.com>
In-Reply-To
<1433621052-5588-1-git-send-email-karthik.188@gmail.com>
Karthik Nayak <karthik.188@gmail.com> writes:
Show 26 quoted lines
> diff --git a/parse-options-cb.c b/parse-options-cb.c
> index be8c413..a4d294d 100644
> --- a/parse-options-cb.c
> +++ b/parse-options-cb.c
> @@ -4,6 +4,7 @@
>  #include "commit.h"
>  #include "color.h"
>  #include "string-list.h"
> +#include "sha1-array.h"
>  ...
> +int parse_opt_points_at(const struct option *opt, const char *arg, int unset)
> +{
> +	unsigned char sha1[20];
> +
> +	if (unset) {
> +		sha1_array_clear(opt->value);
> +		return 0;
> +	}
> +	if (!arg)
> +		return -1;
> +	if (get_sha1(arg, sha1))
> +		return error(_("malformed object name '%s'"), arg);
> +	sha1_array_append(opt->value, sha1);
> +	return 0;
> +}
> +

This feels way too specialized to live as part of parse_options infrastructure.

The existing caller(s) may want to use this callback for parsing "points-at" option they have, but is that the only plausible use of this callback? It looks to be usable by any future caller that wants to take and accumulate any object names into an sha1-array, so perhaps rename it to be a bit more generic to represent its nature better?

	parse_opt_object_name()
or something?

I also wonder if we can (and want to) refactor the users of with-commit callback. Have them use this to obtain an sha1-array and then convert what they received into a commit-list themselves.

Show 15 quoted lines
>  int parse_opt_tertiary(const struct option *opt, const char *arg, int unset)
>  {
>  	int *target = opt->value;
> diff --git a/parse-options.h b/parse-options.h
> index c71e9da..3ae16a1 100644
> --- a/parse-options.h
> +++ b/parse-options.h
> @@ -220,6 +220,7 @@ extern int parse_opt_approxidate_cb(const struct option *, const char *, int);
>  extern int parse_opt_expiry_date_cb(const struct option *, const char *, int);
>  extern int parse_opt_color_flag_cb(const struct option *, const char *, int);
>  extern int parse_opt_verbosity_cb(const struct option *, const char *, int);
> +extern int parse_opt_points_at(const struct option *, const char *, int);
>  extern int parse_opt_with_commit(const struct option *, const char *, int);
>  extern int parse_opt_tertiary(const struct option *, const char *, int);
>  extern int parse_opt_string_list(const struct option *, const char *, int);
Previous: Karthik NayakNext: Karthik Nayak
Message 33 of 37 in “add options to ref-filter”
  1. 0/9 add options to ref-filterKarthik Nayak, Jun 6, 2015
  2. 1/9 tag: libify parse_opt_points_at()Karthik Nayak, Jun 6, 2015
  3. 2/9 ref-filter: implement '--points-at' optionKarthik Nayak, Jun 6, 2015
  4. Matthieu MoyJun 8, 2015
  5. Karthik NayakJun 8, 2015
  6. Matthieu MoyJun 8, 2015
  7. Karthik NayakJun 8, 2015
  8. 3/9 for-each-ref: add '--points-at' optionKarthik Nayak, Jun 6, 2015
  9. Matthieu MoyJun 8, 2015
  10. Karthik NayakJun 8, 2015
  11. Junio C HamanoJun 8, 2015
  12. Karthik NayakJun 9, 2015
  13. Junio C HamanoJun 9, 2015
  14. Karthik NayakJun 10, 2015
  15. Matthieu MoyJun 10, 2015
  16. Karthik NayakJun 10, 2015
  17. 4/9 parse-options: add parse_opt_merge_filter()Karthik Nayak, Jun 6, 2015
  18. Matthieu MoyJun 8, 2015
  19. Karthik NayakJun 8, 2015
  20. Junio C HamanoJun 8, 2015
  21. Karthik NayakJun 9, 2015
  22. 5/9 ref-filter: implement '--merged' and '--no-merged' optionsKarthik Nayak, Jun 6, 2015
  23. Matthieu MoyJun 8, 2015
  24. Karthik NayakJun 8, 2015
  25. 6/9 for-each-ref: add '--merged' and '--no-merged' optionsKarthik Nayak, Jun 6, 2015
  26. Matthieu MoyJun 8, 2015
  27. Karthik NayakJun 8, 2015
  28. 7/9 parse-options.h: add macros for '--contains' optionKarthik Nayak, Jun 6, 2015
  29. Junio C HamanoJun 8, 2015
  30. Karthik NayakJun 9, 2015
  31. 8/9 ref-filter: add '--contains' optionKarthik Nayak, Jun 6, 2015
  32. 9/9 for-each-ref: add '--contains' optionKarthik Nayak, Jun 6, 2015
  33. Junio C HamanoJun 8, 2015
  34. Karthik NayakJun 9, 2015
  35. Christian CouderJun 7, 2015
  36. Karthik NayakJun 8, 2015
  37. Junio C HamanoJun 8, 2015

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.