Re: [PATCH 37/37] replace: rename 'new' variables
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jan 30, 2018, 23:21 UTC
- Message-ID
- <xmqq372nrl0f.fsf@gitster-ct.c.googlers.com>
- In-Reply-To
- <CAGZ79kYwOc3vMsj8DWyNtudM-OBzyw8iTEfKK3nnOJM23GF78A@mail.gmail.com>
Stefan Beller <sbeller@google.com> writes:
Show 23 quoted lines
> On Mon, Jan 29, 2018 at 2:37 PM, Brandon Williams <bmwill@google.com> wrote:
>> Rename C++ keyword in order to bring the codebase closer to being able
>> to be compiled with a C++ compiler.
>>
>> Signed-off-by: Brandon Williams <bmwill@google.com>
>> ---
>> builtin/replace.c | 16 ++++++++--------
>> 1 file changed, 8 insertions(+), 8 deletions(-)
>>
>> diff --git a/builtin/replace.c b/builtin/replace.c
>> index 42cf4f62a..e48835b54 100644
>> --- a/builtin/replace.c
>> +++ b/builtin/replace.c
>> @@ -284,7 +284,7 @@ static int edit_and_replace(const char *object_ref, int force, int raw)
>> {
>> char *tmpfile = git_pathdup("REPLACE_EDITOBJ");
>> enum object_type type;
>> - struct object_id old, new, prev;
>> + struct object_id old, new_oid, prev;
>
> new is a keyword that often comes with a counterpart, here `old`.
> So while at it, also rename old to old_oid ?
> Do we care about the symmetry enough to warrant additional churn for this?Absolutely. That is one of the reasons why the "hacky" approach is so attractive---it does not force those who are doing conversion to think. With this approach, "new" in this context gets replaced with new_oid (because this is about oid; in another codepath, "new" and "old" might have been referring to a file and the new names for them would have been "new_file" vs "old_file") after some thought, and the same thought process should realize "old" must become "old_oid".
Very good point.