git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 00/37] removal of some c++ keywords

From
Stefan Beller <sbeller@google.com>
Date
Jan 31, 2018, 00:57 UTC
Message-ID
<CAGZ79kZNB=3fXOeJwhXGqyBi3mKmE-9nmM-ooXJOzy5OcYaoqQ@mail.gmail.com>
In-Reply-To
<CACsJy8C98HD59DGgqyWtZzj2RVqFe9GN=810A6fs2mMYBh_53Q@mail.gmail.com>
On Tue, Jan 30, 2018 at 4:48 PM, Duy Nguyen <pclouds@gmail.com> wrote:
Show 44 quoted lines
> On Wed, Jan 31, 2018 at 6:01 AM, Stefan Beller <sbeller@google.com> wrote:
>> On Tue, Jan 30, 2018 at 2:36 PM, Junio C Hamano <gitster@pobox.com> wrote:
>>> Duy Nguyen <pclouds@gmail.com> writes:
>>>
>>>> Is it simpler (though hacky) to just  do
>>>>
>>>> #ifdef __cplusplus
>>>> #define new not_new
>>>> #define try really_try
>>>> ...
>>>>
>>>> somewhere in git-compat-util.h?
>>>
>>> Very tempting, especially given that your approach automatically
>>> would cover topics in flight without any merge conflict ;-)
>>>
>>> I agree that it is hacky and somewhat ugly, but the hackiness
>>> somehow does not bother me too much in this case; perhaps because
>>> attempting to use a C++ compiler may already be hacky in the first
>>> place?
>>>
>>> It probably depends on the reason why we are doing this topic.  If a
>>> report about our source code coming from the C++ oriented tool cite
>>> the symbol names seen by machines, then the "hacky" approach will
>>> give us "not_new" where Brandon's patch may give us "new_oid", or
>>> whatever symbol that is more appropriate for the context it appears
>>> than such an automated cute name.
>
> Well. the world after post processing is always ugly. But we could try
> "#define new new__" to get the not so ugly names. new_oid is
> definitely better regardless of c/c++ though so I could see that as a
> good cleanup.
>
>>>> Do we use any C features that are incompatible with C++? (or do we not
>>>> need to care?)
>>>
>>> Good question.
>>
>> implicit casts from void?
>> e.g. xmalloc returns a void pointer, not the type requested.
>> https://embeddedartistry.com/blog/2017/2/28/c-casting-or-oh-no-we-broke-malloc
>
> That causes lots of warnings but not errors (I bit the bullet and
> tried to compile git with g++).

And for g++ there is a flag to disable this specific set of warnings. I think the value of using C++ analysis tools is in the LLVM/clang world, not GNU.

Show 8 quoted lines
> The next set of changes would be to
> reorganize nested enum/struct declarations. Even if nested, C
> considers these flat while C++ sees them in namespaces. There's some
> warnings about confusion with the new cool feature string literals,
> but that's easy to fix.
>
> There's also C99 designator in builtin/clean.c (I thought we avoided
> C99, I can start using this specific feature more now :D)

That was a test balloon? See 512f41cfac (clean.c: use designated initializer, 2017-07-14)

One of the big advantages would be stricter type checking, such as signed/unsigned confusion, that we occasionally have. e.g. 61d36330b4 (prefer "!=" when checking read_in_full() result, 2017-09-27) or what is referenced from there 561598cfcf (read_pack_header: handle signed/unsigned comparison in read result, 2017-09-13).

The bugs resulting in these patches could have been caught more easily with C++ checking IMHO.

> I was stuck at the thread_local thing in index-pack.c and gave up. So
> I don't know what else we would need to change.

Thanks for experimenting! Stefan

> --
> Duy
Previous: Duy NguyenNext: Duy Nguyen
Message 45 of 89 in “removal of some c++ keywords”
  1. 00/37 removal of some c++ keywordsBrandon Williams, Jan 29, 2018
  2. 01/37 object_info: change member name from 'typename' to 'type_name'Brandon Williams, Jan 29, 2018
  3. 02/37 object: rename function 'typename' to 'type_name'Brandon Williams, Jan 29, 2018
  4. 03/37 blame: rename 'this' variablesBrandon Williams, Jan 29, 2018
  5. 04/37 pack-objects: rename 'this' variablesBrandon Williams, Jan 29, 2018
  6. 05/37 rev-parse: rename 'this' variableBrandon Williams, Jan 29, 2018
  7. 06/37 diff: rename 'this' variablesBrandon Williams, Jan 29, 2018
  8. 08/37 apply: rename 'new' variablesBrandon Williams, Jan 29, 2018
  9. 07/37 apply: rename 'try' variablesBrandon Williams, Jan 29, 2018
  10. 09/37 checkout: rename 'new' variablesBrandon Williams, Jan 29, 2018
  11. 14/37 combine-diff: rename 'new' variablesBrandon Williams, Jan 29, 2018
  12. 17/37 diff: rename 'new' variablesBrandon Williams, Jan 29, 2018
  13. 18/37 diffcore-delta: rename 'new' variablesBrandon Williams, Jan 29, 2018
  14. 19/37 entry: rename 'new' variablesBrandon Williams, Jan 29, 2018
  15. 23/37 read-cache: rename 'new' variablesBrandon Williams, Jan 29, 2018
  16. 24/37 ref-filter: rename 'new' variablesBrandon Williams, Jan 29, 2018
  17. 26/37 split-index: rename 'new' variablesBrandon Williams, Jan 29, 2018
  18. 25/37 remote: rename 'new' variablesBrandon Williams, Jan 29, 2018
  19. 22/37 line-log: rename 'new' variablesBrandon Williams, Jan 29, 2018
  20. 30/37 init-db: rename 'template' variablesBrandon Williams, Jan 29, 2018
  21. 31/37 environment: rename 'template' variablesBrandon Williams, Jan 29, 2018
  22. 32/37 diff: rename 'template' variablesBrandon Williams, Jan 29, 2018
  23. 34/37 wrapper: rename 'template' variablesBrandon Williams, Jan 29, 2018
  24. 35/37 tempfile: rename 'template' variablesBrandon Williams, Jan 29, 2018
  25. 36/37 trailer: rename 'template' variablesBrandon Williams, Jan 29, 2018
  26. 37/37 replace: rename 'new' variablesBrandon Williams, Jan 29, 2018
  27. Stefan BellerJan 30, 2018
  28. Junio C HamanoJan 30, 2018
  29. 33/37 environment: rename 'namespace' variablesBrandon Williams, Jan 29, 2018
  30. 27/37 submodule: rename 'new' variablesBrandon Williams, Jan 29, 2018
  31. 28/37 trailer: rename 'new' variablesBrandon Williams, Jan 29, 2018
  32. 29/37 unpack-trees: rename 'new' variablesBrandon Williams, Jan 29, 2018
  33. 21/37 imap-send: rename 'new' variablesBrandon Williams, Jan 29, 2018
  34. 20/37 http: rename 'new' variablesBrandon Williams, Jan 29, 2018
  35. 15/37 commit: rename 'new' variablesBrandon Williams, Jan 29, 2018
  36. 16/37 diff-lib: rename 'new' variableBrandon Williams, Jan 29, 2018
  37. 10/37 help: rename 'new' variablesBrandon Williams, Jan 29, 2018
  38. 13/37 remote: rename 'new' variablesBrandon Williams, Jan 29, 2018
  39. 11/37 pack-redundant: rename 'new' variablesBrandon Williams, Jan 29, 2018
  40. 12/37 reflog: rename 'new' variablesBrandon Williams, Jan 29, 2018
  41. Duy NguyenJan 30, 2018
  42. Junio C HamanoJan 30, 2018
  43. Stefan BellerJan 30, 2018
  44. Duy NguyenJan 31, 2018
  45. Stefan BellerJan 31, 2018
  46. Duy NguyenJan 31, 2018
  47. Johannes SixtJan 30, 2018
  48. 00/37 removal of some c++ keywordsBrandon Williams, Feb 14, 2018
  49. 01/37 object_info: change member name from 'typename' to 'type_name'Brandon Williams, Feb 14, 2018
  50. 02/37 object: rename function 'typename' to 'type_name'Brandon Williams, Feb 14, 2018
  51. 04/37 pack-objects: rename 'this' variablesBrandon Williams, Feb 14, 2018
  52. 03/37 blame: rename 'this' variablesBrandon Williams, Feb 14, 2018
  53. 05/37 rev-parse: rename 'this' variableBrandon Williams, Feb 14, 2018
  54. 06/37 diff: rename 'this' variablesBrandon Williams, Feb 14, 2018
  55. Junio C HamanoFeb 14, 2018
  56. Brandon WilliamsFeb 14, 2018
  57. 09/37 checkout: rename 'new' variablesBrandon Williams, Feb 14, 2018
  58. 10/37 help: rename 'new' variablesBrandon Williams, Feb 14, 2018
  59. 11/37 pack-redundant: rename 'new' variablesBrandon Williams, Feb 14, 2018
  60. 12/37 reflog: rename 'new' variablesBrandon Williams, Feb 14, 2018
  61. 15/37 commit: rename 'new' variablesBrandon Williams, Feb 14, 2018
  62. 16/37 diff-lib: rename 'new' variableBrandon Williams, Feb 14, 2018
  63. 18/37 diffcore-delta: rename 'new' variablesBrandon Williams, Feb 14, 2018
  64. 19/37 entry: rename 'new' variablesBrandon Williams, Feb 14, 2018
  65. 20/37 http: rename 'new' variablesBrandon Williams, Feb 14, 2018
  66. 21/37 imap-send: rename 'new' variablesBrandon Williams, Feb 14, 2018
  67. 22/37 line-log: rename 'new' variablesBrandon Williams, Feb 14, 2018
  68. 23/37 read-cache: rename 'new' variablesBrandon Williams, Feb 14, 2018
  69. 24/37 ref-filter: rename 'new' variablesBrandon Williams, Feb 14, 2018
  70. 26/37 split-index: rename 'new' variablesBrandon Williams, Feb 14, 2018
  71. 25/37 remote: rename 'new' variablesBrandon Williams, Feb 14, 2018
  72. 28/37 trailer: rename 'new' variablesBrandon Williams, Feb 14, 2018
  73. 29/37 unpack-trees: rename 'new' variablesBrandon Williams, Feb 14, 2018
  74. 27/37 submodule: rename 'new' variablesBrandon Williams, Feb 14, 2018
  75. 30/37 init-db: rename 'template' variablesBrandon Williams, Feb 14, 2018
  76. 33/37 environment: rename 'namespace' variablesBrandon Williams, Feb 14, 2018
  77. 34/37 wrapper: rename 'template' variablesBrandon Williams, Feb 14, 2018
  78. 35/37 tempfile: rename 'template' variablesBrandon Williams, Feb 14, 2018
  79. 36/37 trailer: rename 'template' variablesBrandon Williams, Feb 14, 2018
  80. 37/37 replace: rename 'new' variablesBrandon Williams, Feb 14, 2018
  81. 31/37 environment: rename 'template' variablesBrandon Williams, Feb 14, 2018
  82. 32/37 diff: rename 'template' variablesBrandon Williams, Feb 14, 2018
  83. 17/37 diff: rename 'new' variablesBrandon Williams, Feb 14, 2018
  84. 07/37 apply: rename 'try' variablesBrandon Williams, Feb 14, 2018
  85. 14/37 combine-diff: rename 'new' variablesBrandon Williams, Feb 14, 2018
  86. 08/37 apply: rename 'new' variablesBrandon Williams, Feb 14, 2018
  87. Stefan BellerFeb 14, 2018
  88. 13/37 remote: rename 'new' variablesBrandon Williams, Feb 14, 2018
  89. Stefan BellerFeb 14, 2018

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.