Re: [PATCH 00/44] reroll nd/remove-ignore-env.. sb/object-store and sb/packfiles..
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Mar 5, 2018, 19:13 UTC
- Message-ID
- <xmqq371e9vyk.fsf@gitster-ct.c.googlers.com>
- In-Reply-To
- <20180303113637.26518-1-pclouds@gmail.com>
Nguyễn Thái Ngọc Duy <pclouds@gmail.com> writes:
Show 5 quoted lines
> 01/44 - 05/44: nd/remove-ignore-env-field > > This series is moved up top. After this the patch that touch > alternate-db in sha1_file.c looks natural because no env is involved > anymore
Yes, I do like having this upfront and being able to merge it before having to wait for the rest of the huge pile.
Show 12 quoted lines
> I also take this opportunity to introduce a new patch 01/44 to avoid > struct initialization that makes it hard to read and update. Later > patches are also simplified thanks to this. > > 06/44 - 32/44: sb/object-store > > 06/44 is updated to introduce raw_object_store_init() instead of > RAW_OBJECT_STORE_INIT macro. This function is now used to initialize > both main repo and submodule ones. > > 10/44 (moving "packed_git") also introduces two new access wrapper > get_packed_git() and get_packed_git_mru()
I haven't studied individual patches in this round for these, but the interdiff you show below looks quite sensible.
Thanks, will take a bit deeper look at the rest.