git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: How to handle patch series conflicts

From
Junio C Hamano <gitster@pobox.com>
Date
Sep 5, 2018, 21:16 UTC
Message-ID
<xmqq1sa74pd5.fsf@gitster-ct.c.googlers.com>
In-Reply-To
<32028230.38oFsPliiV@thunderbird>
Stephen & Linda Smith <ischis2@cox.net> writes:
Show 14 quoted lines
> Junio -
>
> On Tuesday, September 4, 2018 10:27:26 AM MST Junio C Hamano wrote:
>> > t7500-commit.sh
>> > t7501-commit.sh
>> > t7502-commit.sh
>> > t7509-commit.sh
>> 
>> These seem to have organically grown and it is very likely that ones
>> later introduced were added more from laziness.
>
> How does the project prefer to handle patches that conflict.  Renaming t7501-
> commit.sh will conflict with a patch set that I submitted over the weekend 
> [1].  Should I treat them as totally separate? 

How about not doing the rename before the more important changes solidify? Alternatively, doing the rename as a preparatory clean-up and building the more important changes on top is also possible.

Show 10 quoted lines
> On Tuesday, September 4, 2018 3:36:11 PM MST Junio C Hamano wrote:
>> * sl/commit-dry-run-with-short-output-fix (2018-07-30) 4 commits
>>  . commit: fix exit code when doing a dry run
>>  . wt-status: teach wt_status_collect about merges in progress
>>  . wt-status: rename commitable to committable
>>  . t7501: add coverage for flags which imply dry runs
>
> I noted that this patch set is similar to the one that I just submitted.  Are 
> you thinking of not using mine (in which case I will drop it)?  If not I will 
> add a patch to fix the committable spelling[2] and re-roll.

I think that one that is not even in 'pu' hasn't been looked at for a long time; it is probably a good idea to discard and replace, if you have something working.

Previous: Stefan BellerNext: Stephen & Linda Smith
Message 15 of 21 in “test files with same names?”
  1. Duy NguyenSep 3, 2018
  2. Junio C HamanoSep 4, 2018
  3. 0/5 Commit test name clean-upStephen P. Smith, Oct 23, 2018
  4. 2/5 t7509: cleanup description and filenameStephen P. Smith, Oct 23, 2018
  5. Eric SunshineOct 23, 2018
  6. 1/5 t2000: rename and combine checkout clash testsStephen P. Smith, Oct 23, 2018
  7. 4/5 t7500: rename commit tests script to comply with naming conventionStephen P. Smith, Oct 23, 2018
  8. Eric SunshineOct 23, 2018
  9. 3/5 t7502: rename commit test script to comply with naming conventionStephen P. Smith, Oct 23, 2018
  10. 5/5 t7501: rename commit test to comply with naming conventionStephen P. Smith, Oct 23, 2018
  11. Eric SunshineOct 23, 2018
  12. Stephen & Linda SmithSep 4, 2018
  13. How to handle patch series conflictsStephen & Linda Smith, Sep 5, 2018
  14. Stefan BellerSep 5, 2018
  15. Junio C HamanoSep 5, 2018
  16. Stephen & Linda SmithOct 8, 2018
  17. Junio C HamanoOct 9, 2018
  18. Stephen SmithOct 9, 2018
  19. Stephen & Linda SmithSep 5, 2018
  20. Stephen & Linda SmithSep 5, 2018
  21. Stephen SmithSep 7, 2018

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.