git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 0/5] Commit test name clean-up

From
SSStephen P. Smith <ischis2@cox.net>
Date
Oct 23, 2018, 03:53 UTC
Message-ID
<20181023035341.15398-1-ischis2@cox.net>
In-Reply-To
<xmqqwos19nr5.fsf@gitster-ct.c.googlers.com>
Several tests did not comply with the documented test naming standard.

The patch series was held off until updates to t7501 was merged to the master branch.

Stephen P. Smith (5):
  t2000: rename and combine checkout clash tests
  t7509: cleanup description and filename
  t7502: rename commit test script to comply with naming convention
  t7500: rename commit tests script to comply with naming convention
  t7501: rename commit test to comply with naming convention
 t/t2000-checkout-cache-clash.sh               |  60 --------
 t/t2000-conflict-when-checking-files-out.sh   | 135 ++++++++++++++++++
 t/t2001-checkout-cache-clash.sh               |  85 -----------
 ...> t7500-commit-template-squash-signoff.sh} |   2 +-
 ....sh => t7501-commit-basic-funtionality.sh} |   0
 ...02-commit.sh => t7502-commit-porcelain.sh} |   0
 ...9-commit.sh => t7509-commit-authorship.sh} |   2 +-
 7 files changed, 137 insertions(+), 147 deletions(-)
 delete mode 100755 t/t2000-checkout-cache-clash.sh
 create mode 100755 t/t2000-conflict-when-checking-files-out.sh
 delete mode 100755 t/t2001-checkout-cache-clash.sh
 rename t/{t7500-commit.sh => t7500-commit-template-squash-signoff.sh} (99%)
 rename t/{t7501-commit.sh => t7501-commit-basic-funtionality.sh} (100%)
 rename t/{t7502-commit.sh => t7502-commit-porcelain.sh} (100%)
 rename t/{t7509-commit.sh => t7509-commit-authorship.sh} (98%)
-- 
2.19.0
Previous: Junio C HamanoNext: Stephen P. Smith
Message 3 of 21 in “test files with same names?”
  1. Duy NguyenSep 3, 2018
  2. Junio C HamanoSep 4, 2018
  3. 0/5 Commit test name clean-upStephen P. Smith, Oct 23, 2018
  4. 2/5 t7509: cleanup description and filenameStephen P. Smith, Oct 23, 2018
  5. Eric SunshineOct 23, 2018
  6. 1/5 t2000: rename and combine checkout clash testsStephen P. Smith, Oct 23, 2018
  7. 4/5 t7500: rename commit tests script to comply with naming conventionStephen P. Smith, Oct 23, 2018
  8. Eric SunshineOct 23, 2018
  9. 3/5 t7502: rename commit test script to comply with naming conventionStephen P. Smith, Oct 23, 2018
  10. 5/5 t7501: rename commit test to comply with naming conventionStephen P. Smith, Oct 23, 2018
  11. Eric SunshineOct 23, 2018
  12. Stephen & Linda SmithSep 4, 2018
  13. How to handle patch series conflictsStephen & Linda Smith, Sep 5, 2018
  14. Stefan BellerSep 5, 2018
  15. Junio C HamanoSep 5, 2018
  16. Stephen & Linda SmithOct 8, 2018
  17. Junio C HamanoOct 9, 2018
  18. Stephen SmithOct 9, 2018
  19. Stephen & Linda SmithSep 5, 2018
  20. Stephen & Linda SmithSep 5, 2018
  21. Stephen SmithSep 7, 2018

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.