git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: test files with same names?

From
SSStephen & Linda Smith <ischis2@cox.net>
Date
Sep 4, 2018, 18:04 UTC
Message-ID
<2293750.yp9BkL5mAn@thunderbird>
In-Reply-To
<CACsJy8B1UDN26tWPvOtixSBiFF6bYP2BtK2n1u4W-tWdVeKK1A@mail.gmail.com>
I don't mind doing this.
On Tuesday, September 4, 2018 10:27:26 AM MST Junio C Hamano wrote:
Show 31 quoted lines
> Duy Nguyen <pclouds@gmail.com> writes:
> > t2000-checkout-cache-clash.sh
> > t2001-checkout-cache-clash.sh
> 
> These date back to 368f99d5 ("[PATCH 2/2] The core GIT tests: recent
> additions and fixes.", 2005-05-13) which later were renamed by
> f50c9f76 ("Rename some test scripts and describe the naming
> convention", 2005-05-15).  One was about checking out a regular file
> to a path where a directory currently sits, and the other is about
> checking out a regular file that requires a parent directory at a
> path where a regular file currently occupies.  These days, I suspect
> that we would make these into a single "d/f conflict when checking
> files out" test script, and f50c9f76 might have been a good chance
> to do such a clean-up.  If somebody cares deeply enough, I do not
> mind seeing a belated clean-up, either.
> 
> > t7500-commit.sh
> > t7501-commit.sh
> > t7502-commit.sh
> > t7509-commit.sh
> 
> These seem to have organically grown and it is very likely that ones
> later introduced were added more from laziness.
> 
> If somebody wants to clean them up, probably the first thing to do
> is to study them to come up with a clear $test_description for each
> of them.  I think t7509 says --reset-author and it may have started
> as a test on that single feature, but it now covers other ways to
> set and/or preserve authorship information, so it may make sense to
> update its $test_description to "commit authorship" or something,
> for example.
Previous: Eric SunshineNext: Stephen & Linda Smith
Message 12 of 21 in “test files with same names?”
  1. Duy NguyenSep 3, 2018
  2. Junio C HamanoSep 4, 2018
  3. 0/5 Commit test name clean-upStephen P. Smith, Oct 23, 2018
  4. 2/5 t7509: cleanup description and filenameStephen P. Smith, Oct 23, 2018
  5. Eric SunshineOct 23, 2018
  6. 1/5 t2000: rename and combine checkout clash testsStephen P. Smith, Oct 23, 2018
  7. 4/5 t7500: rename commit tests script to comply with naming conventionStephen P. Smith, Oct 23, 2018
  8. Eric SunshineOct 23, 2018
  9. 3/5 t7502: rename commit test script to comply with naming conventionStephen P. Smith, Oct 23, 2018
  10. 5/5 t7501: rename commit test to comply with naming conventionStephen P. Smith, Oct 23, 2018
  11. Eric SunshineOct 23, 2018
  12. Stephen & Linda SmithSep 4, 2018
  13. How to handle patch series conflictsStephen & Linda Smith, Sep 5, 2018
  14. Stefan BellerSep 5, 2018
  15. Junio C HamanoSep 5, 2018
  16. Stephen & Linda SmithOct 8, 2018
  17. Junio C HamanoOct 9, 2018
  18. Stephen SmithOct 9, 2018
  19. Stephen & Linda SmithSep 5, 2018
  20. Stephen & Linda SmithSep 5, 2018
  21. Stephen SmithSep 7, 2018

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.