Re: [PATCH v5 2/4] Introduce "double conversion during merge" more gradually
- From
Jakub Narebski <jnareb@gmail.com>
- Date
- Jul 1, 2010, 20:15 UTC
- Message-ID
- <m3aaqbnemz.fsf@localhost.localdomain>
- In-Reply-To
- <20100701185712.GA22421@pvv.org>
Finn Arne Gangstad <finnag@pvv.org> writes:
Show 22 quoted lines
> On Thu, Jul 01, 2010 at 10:05:17AM -0700, Jakub Narebski wrote: >> Eyvind Bernhardsen <eyvind.bernhardsen@gmail.com> writes: >>> On 1. juli 2010, at 18:25, Junio C Hamano <gitster@pobox.com> wrote: >>>> Johannes Sixt <j.sixt@viscovery.net> writes: >>>>> Am 7/1/2010 11:09, schrieb Eyvind Bernhardsen: >>>>> >>>>>> +core.mergePrefilter:: >> [...] >>>> >>>> Somehow to me "prefilter" does not sound to convey what really is going on >>>> here, though. >>> >>> "Doubleconvert" doesn't really mean anything either though, and >>> "convert" and "normalise" are too generic. I think the problem is >>> that there's no existing name for what convert.c does. >>> >>> I chose "filter" because of the filter property; the crlf and ident >>> things can be regarded as built-in filters. -- Eyvind >> >> What about `merge.renormalize' ;-) ? > > Best so far! Or what about "merge.canonicalize"? Sorry for bikeshedding :)
Perhaps `merge.regularize'? Or `merge.normalizeToWorkTree'? It is about converting to worktree version according to current settings, IIUC...
-- Jakub Narebski Poland ShadeHawk on #git