Re: [PATCH v5 2/4] Introduce "double conversion during merge" more gradually
On 1. juli 2010, at 22.15, Jakub Narebski wrote:
Show 9 quoted lines
> Finn Arne Gangstad <finnag@pvv.org> writes:
>> On Thu, Jul 01, 2010 at 10:05:17AM -0700, Jakub Narebski wrote:
>>> What about `merge.renormalize' ;-) ?
>>
>> Best so far! Or what about "merge.canonicalize"? Sorry for bikeshedding :)
>
> Perhaps `merge.regularize'? Or `merge.normalizeToWorkTree'?
> It is about converting to worktree version according to current
> settings, IIUC...
Almost, it's about converting to the _repository_ version according to current (that is, merged) settings. Since the content is already in repository format it needs to be converted to the worktree version before it is converted back, hence Junio's "doubleConvert".
"merge.renormalizeUsingMergedGitattributes"?
--
Eyvind